Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004309 [Resin] major always 11-02-10 08:53 01-11-11 10:37
Reporter reza View Status public  
Assigned To ferg
Priority high Resolution fixed  
Status closed   Product Version 4.0.13
Summary 0004309: Instance Restart Does Not Work
Description The "restart" command fails consistently. The instance is stopped and an exception is thrown but the restart command never finished and the instance is not brought back up.

The following is the exception thrown:
================================================================================
com.caucho.remote.websocket.WebSocketClient$ClientContex
t run
WARNING: java.net.SocketException: Connection reset
java.net.SocketException: Connection reset
        at java.net.SocketInputStream.read(Unknown Source)
        at com.caucho.vfs.VfsStream.read(VfsStream.java:140)
        at com.caucho.vfs.ReadStream.readBuffer(ReadStream.java:1237)
        at com.caucho.vfs.ReadStream.waitForRead(ReadStream.java:380)
        at
com.caucho.remote.websocket.WebSocketClient$ClientContext.handleReque
sts(WebSocketClient.java:295)
        at
com.caucho.remote.websocket.WebSocketClient$ClientContext.run(WebSock
etClient.java:274)
        at java.lang.Thread.run(Unknown Source)
Nov 29, 2010 7:04:52 PM com.caucho.env.thread.ResinThread runTasks
WARNING: com.caucho.bam.ProtocolException: java.net.SocketException:
Connection
reset by peer: socket write error
com.caucho.bam.ProtocolException: java.net.SocketException: Connection reset
by
peer: socket write error
        at com.caucho.hmtp.HmtpWriter.querySet(HmtpWriter.java:251)
        at com.caucho.hemp.packet.QuerySet.dispatch(QuerySet.java:84)
        at
com.caucho.hemp.broker.HempMemoryQueue.dispatch(HempMemoryQueue.java:
252)
        at com.caucho.hemp.broker.QueueWorker.runTask(QueueWorker.java:77)
        at com.caucho.env.thread.TaskWorker.run(TaskWorker.java:143)
        at com.caucho.env.thread.ResinThread.runTasks(ResinThread.java:182)
        at com.caucho.env.thread.ResinThread.run(ResinThread.java:126)
Caused by: java.net.SocketException: Connection reset by peer: socket write
erro
r
        at java.net.SocketOutputStream.socketWrite0(Native Method)
        at java.net.SocketOutputStream.socketWrite(Unknown Source)
        at java.net.SocketOutputStream.write(Unknown Source)
        at com.caucho.vfs.VfsStream.write(VfsStream.java:201)
        at com.caucho.vfs.WriteStream.flush(WriteStream.java:376)
        at
com.caucho.hessian.io.Hessian2Output.flush(Hessian2Output.java:1545)
        at com.caucho.hmtp.HmtpWriter.querySet(HmtpWriter.java:245)
        ... 6 more
================================================================================
Additional Information
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
11-02-10 08:53 reza New Issue
01-11-11 10:37 ferg Assigned To  => ferg
01-11-11 10:37 ferg Status new => closed
01-11-11 10:37 ferg Resolution open => fixed
01-11-11 10:37 ferg Fixed in Version  => 4.0.14


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
27 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker