Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004281 [Resin] major always 11-03-10 02:05 01-13-11 09:37
Reporter vicsanca View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.12
Summary 0004281: mod_caucho not compiling in centos 5.5 64bit
Description Apache 2.2 installed from centos cd. Tried almost any configure option. The most complete one:

./configure --prefix=/usr/resin --with-resin-root=/usr/resin/webapps/ROOT --with-resin-log=/usr/resin/log --with-resin-conf=/usr/resin/conf --enable-64bit --with-apache-conf=/etc/httpd/conf --with-apxs=/usr/sbin/apxs --with-apache-include=/usr/include/httpd --with-apache-libexec=/usr/lib64/httpd/module

Error compiling caucho module:
make[2]: se ingresa al directorio `/usr/resin/modules/c/src/apache2'
EGREP="/bin/grep -E" /usr/resin/libtool --silent --tag=CXX --mode=link gcc -module -o mod_caucho.la -avoid-version -rpath @apache_libexec@ mod_caucho.lo ../common/stream.lo ../common/config.lo ../common/memory.lo
libtool: ignoring unknown tag CXX
libtool: link: only absolute run-paths are allowed
make[2]: *** [mod_caucho.la] Error 1
make[2]: se sale del directorio `/usr/resin/modules/c/src/apache2'
Additional Information [root@idsdev resin]# ./configure --prefix=/usr/resin --with-resin-root=/usr/resin/webapps/ROOT --with-resin-log=/usr/resin/log --with-resin-conf=/usr/resin/conf --enable-64bit --with-apache-conf=/etc/httpd/conf --with-apxs=/usr/sbin/apxs --with-apache-include=/usr/include/httpd --with-apache-libexec=/usr/lib64/httpd/modules
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... none
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for egrep... (cached) /bin/grep -E
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking sys/poll.h usability... yes
checking sys/poll.h presence... yes
checking for sys/poll.h... yes
checking sys/epoll.h usability... yes
checking sys/epoll.h presence... yes
checking for sys/epoll.h... yes
checking for JAVA_HOME... /usr/java/jdk1.6.0_22
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 98304
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
Using shared library flags from /usr/sbin/apxs
checking if /usr/java/jdk1.6.0_22/bin/java -d64 is Java 1.6... yes
checking if Java is 64-bit... yes
Using Apache 2.0 configuration /etc/httpd/conf
Using Apache CFLAGS: -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -pthread
checking if /bin/cp accepts -u... yes
checking for JNI in /usr/java/jdk1.6.0_22/include/linux ... found
Using JVMTI for class reloading
Openssl library was not found
configure: creating ./config.status
config.status: creating Makefile
config.status: creating modules/c/src/Makefile
config.status: creating modules/c/src/common/Makefile
config.status: creating modules/c/src/apache2/Makefile
config.status: creating modules/c/src/resin_os/Makefile
config.status: creating init.d/resin
config.status: executing depfiles commands
config.status: executing libtool commands
configure: creating ./config.status
config.status: creating Makefile
config.status: creating modules/c/src/Makefile
config.status: creating modules/c/src/common/Makefile
config.status: creating modules/c/src/apache2/Makefile
config.status: creating modules/c/src/resin_os/Makefile
config.status: creating init.d/resin
config.status: creating ./modules/c/src/Makefile
config.status: creating ./modules/c/src/resin/Makefile
config.status: creating ./modules/c/src/resinssl/Makefile
config.status: executing depfiles commands
config.status: executing libtool commands


Resin Configuration summary:

  RESIN_HOME: /usr/resin
      root: /usr/resin/webapps/ROOT
      conf: /usr/resin/conf
      log : /usr/resin/log
      init: /etc/init.d/resin
  JAVA_HOME: /usr/java/jdk1.6.0_22

    + 64-bit JNI in -I/usr/java/jdk1.6.0_22/include -I/usr/java/jdk1.6.0_22/include/linux
    + JNI CFLAGS: -g -O2 -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI
    + epoll() for keepalives
    + not using OpenSSL

  Apache: /etc/httpd
      conf: /etc/httpd/conf
      libexec: /usr/lib64/httpd/modules
      include: /usr/include/httpd
      CFLAGS: -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -pthread


[root@idsdev resin]# make
Makefile:283: atención: se imponen comandos para el objetivo `modules/c/src/Makefile'
Makefile:273: atención: se ignoran las instrucciones viejas para el objetivo `modules/c/src/Makefile'
(cd modules/c/src; make)
make[1]: se ingresa al directorio `/usr/resin/modules/c/src'
for dir in common apache2 resin_os ; do (cd $dir; make); done
make[2]: se ingresa al directorio `/usr/resin/modules/c/src/common'
gcc -c -g -O2 -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI stream.c
stream.c: In function select_host:
stream.c:1394: aviso: conversión de puntero a entero de tamaño diferente
gcc -c -g -O2 -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI config.c
gcc -c -g -O2 -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI memory.c
/usr/resin/libtool --silent --mode=compile gcc -o stream.lo -c -g -O2 -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI stream.c
stream.c: In function select_host:
stream.c:1394: aviso: conversión de puntero a entero de tamaño diferente
/usr/resin/libtool --silent --mode=compile gcc -o config.lo -c -g -O2 -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI config.c
/usr/resin/libtool --silent --mode=compile gcc -o memory.lo -c -g -O2 -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI memory.c
make[2]: se sale del directorio `/usr/resin/modules/c/src/common'
make[2]: se ingresa al directorio `/usr/resin/modules/c/src/apache2'
EGREP="/bin/grep -E" /usr/resin/libtool --silent --tag=CXX --mode=compile gcc -o mod_caucho.lo -c -I/usr/include/httpd -I/usr/include/apr-1 -DRESIN_HOME=\"/usr/resin\" -I../common -g -O2 -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -pthread mod_caucho.c
libtool: ignoring unknown tag CXX
EGREP="/bin/grep -E" /usr/resin/libtool --silent --tag=CXX --mode=link gcc -module -o mod_caucho.la -avoid-version -rpath @apache_libexec@ mod_caucho.lo ../common/stream.lo ../common/config.lo ../common/memory.lo
libtool: ignoring unknown tag CXX
libtool: link: only absolute run-paths are allowed
make[2]: *** [mod_caucho.la] Error 1
make[2]: se sale del directorio `/usr/resin/modules/c/src/apache2'
make[2]: se ingresa al directorio `/usr/resin/modules/c/src/resin_os'
gcc -g -O2 -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI -m64 -fPIC -DRESIN_HOME=\"/usr/resin\" -I/usr/java/jdk1.6.0_22/include -I/usr/java/jdk1.6.0_22/include/linux -I../common -DCPU=\"x86_64\" -DOS= -c -o boot.o boot.c
gcc -g -O2 -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI -m64 -fPIC -DRESIN_HOME=\"/usr/resin\" -I/usr/java/jdk1.6.0_22/include -I/usr/java/jdk1.6.0_22/include/linux -I../common -DCPU=\"x86_64\" -DOS= -c -o java.o java.c
gcc -g -O2 -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI -m64 -fPIC -DRESIN_HOME=\"/usr/resin\" -I/usr/java/jdk1.6.0_22/include -I/usr/java/jdk1.6.0_22/include/linux -I../common -DCPU=\"x86_64\" -DOS= -c -o jni_os.o jni_os.c
gcc -g -O2 -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI -m64 -fPIC -DRESIN_HOME=\"/usr/resin\" -I/usr/java/jdk1.6.0_22/include -I/usr/java/jdk1.6.0_22/include/linux -I../common -DCPU=\"x86_64\" -DOS= -c -o jni_jvmti.o jni_jvmti.c
gcc -g -O2 -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI -m64 -fPIC -DRESIN_HOME=\"/usr/resin\" -I/usr/java/jdk1.6.0_22/include -I/usr/java/jdk1.6.0_22/include/linux -I../common -DCPU=\"x86_64\" -DOS= -c -o jni_socket.o jni_socket.c
gcc -g -O2 -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI -m64 -fPIC -DRESIN_HOME=\"/usr/resin\" -I/usr/java/jdk1.6.0_22/include -I/usr/java/jdk1.6.0_22/include/linux -I../common -DCPU=\"x86_64\" -DOS= -c -o memory.o memory.c
gcc -g -O2 -DPOLL -DEPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -m64 -fPIC -DHAS_SOCK_TIMEOUT -DHAS_JVMTI -m64 -fPIC -DRESIN_HOME=\"/usr/resin\" -I/usr/java/jdk1.6.0_22/include -I/usr/java/jdk1.6.0_22/include/linux -I../common -DCPU=\"x86_64\" -DOS= -c -o std.o std.c
gcc -shared -fPIC -o libresin_os.so boot.o java.o jni_os.o jni_jvmti.o jni_socket.o memory.o std.o -lpthread -lc
make[2]: se sale del directorio `/usr/resin/modules/c/src/resin_os'
make[1]: se sale del directorio `/usr/resin/modules/c/src'
if test -r ./modules/c/src/Makefile; then \
          cd ./modules/c/src; make; \
        fi
make[1]: se ingresa al directorio `/usr/resin/modules/c/src'
for dir in common apache2 resin_os ; do (cd $dir; make); done
make[2]: se ingresa al directorio `/usr/resin/modules/c/src/common'
make[2]: No se hace nada para `all'.
make[2]: se sale del directorio `/usr/resin/modules/c/src/common'
make[2]: se ingresa al directorio `/usr/resin/modules/c/src/apache2'
EGREP="/bin/grep -E" /usr/resin/libtool --silent --tag=CXX --mode=link gcc -module -o mod_caucho.la -avoid-version -rpath @apache_libexec@ mod_caucho.lo ../common/stream.lo ../common/config.lo ../common/memory.lo
libtool: ignoring unknown tag CXX
libtool: link: only absolute run-paths are allowed
make[2]: *** [mod_caucho.la] Error 1
make[2]: se sale del directorio `/usr/resin/modules/c/src/apache2'
make[2]: se ingresa al directorio `/usr/resin/modules/c/src/resin_os'
make[2]: No se hace nada para `all'.
make[2]: se sale del directorio `/usr/resin/modules/c/src/resin_os'
make[1]: se sale del directorio `/usr/resin/modules/c/src'
Attached Files

- Relationships

- Notes
(0004816)
vicsanca
11-03-10 04:28

Same error on 32bit version of centos 5.5.
 
(0004817)
vicsanca
11-03-10 04:33

With Resin 4.0.10 mod_caucho.so compiles fine with apache. Problem is located in new 4.0.12 version
 
(0004859)
vicsanca
11-30-10 08:15

Seems to be solved in 4.0.13
 

- Issue History
Date Modified Username Field Change
11-03-10 02:05 vicsanca New Issue
11-03-10 04:28 vicsanca Note Added: 0004816
11-03-10 04:33 vicsanca Note Added: 0004817
11-03-10 04:35 vicsanca Issue Monitored: vicsanca
11-30-10 08:15 vicsanca Note Added: 0004859
01-13-11 09:37 ferg Assigned To  => ferg
01-13-11 09:37 ferg Status new => closed
01-13-11 09:37 ferg Resolution open => fixed
01-13-11 09:37 ferg Fixed in Version  => 4.0.13
01-13-11 09:37 ferg Additional Information Updated


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
35 total queries executed.
28 unique queries executed.
Powered by Mantis Bugtracker