Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004235 [Resin] minor always 09-01-10 10:19 01-14-11 11:31
Reporter alex View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.11
Summary 0004235: resin-jspc ant task is broken
Description resin-pro-4.0.11 $ant
Buildfile: build.xml

test:
[resin-jspc] com.caucho.config.ConfigRuntimeException: java.lang.ClassNotFoundException: com.caucho.server.resin.EnvInit
[resin-jspc]
[resin-jspc] at com.caucho.config.ConfigException.create(ConfigException.java:168)
[resin-jspc]
[resin-jspc] at com.caucho.loader.Environment.initializeEnvironment(Environment.java:946)
[resin-jspc]
[resin-jspc] at com.caucho.loader.Environment.init(Environment.java:305)
[resin-jspc]
[resin-jspc] at com.caucho.env.service.ResinSystem.<init>(ResinSystem.java:123)
[resin-jspc]
[resin-jspc] at com.caucho.env.service.ResinSystem.<init>(ResinSystem.java:87)
[resin-jspc]
[resin-jspc] at com.caucho.jsp.JspCompiler.<init>(JspCompiler.java:114)
[resin-jspc]
[resin-jspc] at com.caucho.jsp.JspCompiler.main(JspCompiler.java:610)
[resin-jspc]
[resin-jspc] at com.caucho.ant.Jspc.execute(Jspc.java:103)
[resin-jspc]
[resin-jspc] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[resin-jspc]
[resin-jspc] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[resin-jspc]
[resin-jspc] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[resin-jspc]
[resin-jspc] at java.lang.reflect.Method.invoke(Method.java:597)
[resin-jspc]
[resin-jspc] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
[resin-jspc]
[resin-jspc] at org.apache.tools.ant.TaskAdapter.execute(TaskAdapter.java:134)
[resin-jspc]
[resin-jspc] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
[resin-jspc]
[resin-jspc] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[resin-jspc]
[resin-jspc] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[resin-jspc]
[resin-jspc] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[resin-jspc]
[resin-jspc] at java.lang.reflect.Method.invoke(Method.java:597)
[resin-jspc]
[resin-jspc] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
[resin-jspc]
[resin-jspc] at org.apache.tools.ant.Task.perform(Task.java:348)
[resin-jspc]
[resin-jspc] at org.apache.tools.ant.Target.execute(Target.java:357)
[resin-jspc]
[resin-jspc] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[resin-jspc]
[resin-jspc] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
[resin-jspc]
[resin-jspc] at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
[resin-jspc]
[resin-jspc] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
[resin-jspc]
[resin-jspc] at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
[resin-jspc]
[resin-jspc] at org.apache.tools.ant.Main.runBuild(Main.java:698)
[resin-jspc]
[resin-jspc] at org.apache.tools.ant.Main.startAnt(Main.java:199)
[resin-jspc]
[resin-jspc] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
[resin-jspc]
[resin-jspc] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
[resin-jspc]
[resin-jspc] Caused by: java.lang.ClassNotFoundException: com.caucho.server.resin.EnvInit
[resin-jspc]
[resin-jspc] at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
[resin-jspc]
[resin-jspc] at java.security.AccessController.doPrivileged(Native Method)
[resin-jspc]
[resin-jspc] at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
[resin-jspc]
[resin-jspc] at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
[resin-jspc]
[resin-jspc] at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
[resin-jspc]
[resin-jspc] at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
[resin-jspc]
[resin-jspc] at java.lang.Class.forName0(Native Method)
[resin-jspc]
[resin-jspc] at java.lang.Class.forName(Class.java:247)
[resin-jspc]
[resin-jspc] at com.caucho.loader.Environment.initializeEnvironment(Environment.java:940)
[resin-jspc]
[resin-jspc] ... 29 more
[resin-jspc]

BUILD FAILED
/tmp/resin-pro-4.0.11/build.xml:15: classpath:com/caucho/resin/resin-embed.xml:4: com.caucho.config.ConfigException: <class-loader> requires an EnvironmentClassLoader.

2: xmlns:resin="urn:java:com.caucho.resin">
3:
4: <class-loader>
5: <tree-loader path="${resin.root}/ext-lib"/>
6: </class-loader>


Total time: 1 second
Additional Information workaround: use resin-4.0.10 with the ant task
Attached Files

- Relationships

- Notes
(0004937)
ferg
01-14-11 11:31

support/1040
 

- Issue History
Date Modified Username Field Change
09-01-10 10:19 alex New Issue
09-01-10 10:27 jnovak Issue Monitored: jnovak
01-14-11 11:31 ferg Note Added: 0004937
01-14-11 11:31 ferg Assigned To  => ferg
01-14-11 11:31 ferg Status new => closed
01-14-11 11:31 ferg Resolution open => fixed
01-14-11 11:31 ferg Fixed in Version  => 4.0.15


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker