Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004197 [Resin] minor always 08-03-10 12:46 01-12-11 15:31
Reporter alex View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.10
Summary 0004197: java -jar resin/lib/resin.jar -root-directory resin start -> fails from resin's parent directory
Description change to the parent directory of resin-home
issue a start command: java -jar resin/lib/resin.jar -root-directory resin start

watchdog-manager.log:

[2010/08/31 12:40:11.720] java.io.IOException: Cannot run program "C:\Program Files\java\jdk1.6.0_18\bin\javaw" (in directory "C:\appservers\resin-pro-4.0.10\resin-pro-4.0.10"): CreateProcess error=267, The directory name is invalid
                              at java.lang.ProcessBuilder.start(ProcessBuilder.java:459)
                              at com.caucho.boot.WatchdogChildProcess.createProcess(WatchdogChildProcess.java:484)
                              at com.caucho.boot.WatchdogChildProcess.run(WatchdogChildProcess.java:135)
                              at com.caucho.boot.WatchdogChildTask.run(WatchdogChildTask.java:175)
                              at com.caucho.env.thread.ResinThread.runTasks(ResinThread.java:170)
                              at com.caucho.env.thread.ResinThread.run(ResinThread.java:126)
                          Caused by: java.io.IOException: CreateProcess error=267, The directory name is invalid
                              at java.lang.ProcessImpl.create(Native Method)
                              at java.lang.ProcessImpl.<init>(ProcessImpl.java:81)
                              at java.lang.ProcessImpl.start(ProcessImpl.java:30)
                              at java.lang.ProcessBuilder.start(ProcessBuilder.java:452)
Additional Information
Attached Files

- Relationships

- Notes
(0004923)
ferg
01-12-11 15:31

network/0395
 

- Issue History
Date Modified Username Field Change
08-03-10 12:46 alex New Issue
01-12-11 15:31 ferg Note Added: 0004923
01-12-11 15:31 ferg Assigned To  => ferg
01-12-11 15:31 ferg Status new => closed
01-12-11 15:31 ferg Resolution open => fixed
01-12-11 15:31 ferg Fixed in Version  => 4.0.15


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker