Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004193 [Resin] minor always 08-02-10 17:28 11-15-10 11:39
Reporter voodude View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0004193: HessianServlet extend HttpServlet instead of GenericServlet
Description Would it be possible for HessianServlet to extend HttpServlet instead of GenericServlet?

Google Guice (no JSR299 support on appengine, unfortunately) requires that managed servlets be derived from HttpServlet. Since the first thing that the HessianServlet.service() does is cast the req and resp to the Http- equivalents, seems like overriding HttpServlet.service(HttpServletRequest, HttpServletResponse) makes more sense anyways.

Thanks,
Jeff
Additional Information
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
08-02-10 17:28 voodude New Issue
10-08-10 14:52 voodude Issue Monitored: voodude
11-15-10 11:39 ferg Assigned To  => ferg
11-15-10 11:39 ferg Status new => closed
11-15-10 11:39 ferg Resolution open => fixed
11-15-10 11:39 ferg Fixed in Version  => 4.0.14


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
28 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker