Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004095 [Resin] minor always 06-02-10 09:20 01-14-11 12:48
Reporter alex View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.7
Summary 0004095: apache & resin & keepalive-select-enable
Description apache returns 503, while resin logs failed keepalive (select) for requests.

[2010-06-30 08:11:22.931] [TldManager - INFO (com.caucho.jsp.TldManager.initGlobal)]: Loading .tld files from global classpath
[2010-06-30 08:11:24.087] [ClassEntry - CONFIG (com.caucho.loader.ClassEntry.<clinit>)]: In-place class redefinition (HotSwap) is available.
[2010-06-30 08:11:27.806] [TcpSocketLink - WARNING (com.caucho.network.listen.TcpSocketLink.processKeepalive)]: TcpSocketLink[id=1,gandalf] failed keepalive (select)
[2010-06-30 08:11:27.806] [TcpSocketLink - WARNING (com.caucho.network.listen.TcpSocketLink.processKeepalive)]: TcpSocketLink[id=2,gandalf] failed keepalive (select)
[2010-06-30 08:11:27.822] [TcpSocketLink - WARNING (com.caucho.network.listen.TcpSocketLink.processKeepalive)]: TcpSocketLink[id=3,gandalf] failed keepalive (select)
[2010-06-30 08:11:34.072] [TcpSocketLink - WARNING (com.caucho.network.listen.TcpSocketLink.processKeepalive)]: TcpSocketLink[id=1,gandalf] failed keepalive (select)
[2010-06-30 08:11:34.072] [TcpSocketLink - WARNING (com.caucho.network.listen.TcpSocketLink.processKeepalive)]: TcpSocketLink[id=4,gandalf] failed keepalive (select)
[2010-06-30 08:11:34.087] [TcpSocketLink - WARNING (com.caucho.network.listen.TcpSocketLink.processKeepalive)]: TcpSocketLink[id=5,gandalf] failed keepalive (select)
[2010-06-30 08:11:34.103] [TcpSocketLink - WARNING (com.caucho.network.listen.TcpSocketLink.processKeepalive)]: TcpSocketLink[id=6,gandalf] failed keepalive (select)
[2010-06-30 08:11:34.119] [TcpSocketLink - WARNING (com.caucho.network.listen.TcpSocketLink.processKeepalive)]: TcpSocketLink[id=2,gandalf] failed keepalive (select)
 
Additional Information see thread with Brian Deng for details and configuration
Attached Files  server.log [^] (448,148 bytes) 06-02-10 09:45
 server.log.finer.gz [^] (30,310 bytes) 06-02-10 10:42

- Relationships

- Notes
(0004648)
briandeng
06-02-10 10:42

Added server.log.finer.gz. This is with com.caucho logger-name set to 'finer'.
Encountered a few 503 errors during this interaction.
 
(0004649)
phcollard
06-02-10 12:36

FYI I encounter the exact same issue with IIS. Returns "Server Down For Maintenance" every 7-8 page browsed although Resin is up all this time.

In logs :
[2010/06/30 14:20:37.305] TcpSocketLink[id=1,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:10.446] TcpSocketLink[id=5,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:10.524] TcpSocketLink[id=1,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:10.539] TcpSocketLink[id=4,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:10.758] TcpSocketLink[id=2,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:10.774] TcpSocketLink[id=3,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:10.774] TcpSocketLink[id=6,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:21.633] TcpSocketLink[id=1,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:21.633] TcpSocketLink[id=2,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:21.633] TcpSocketLink[id=5,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:21.649] TcpSocketLink[id=8,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:21.680] TcpSocketLink[id=7,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:21.696] TcpSocketLink[id=4,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:27.117] TcpSocketLink[id=1,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:27.117] TcpSocketLink[id=8,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:27.117] TcpSocketLink[id=2,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:27.133] TcpSocketLink[id=5,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:27.180] TcpSocketLink[id=6,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:27.196] TcpSocketLink[id=3,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:29.821] TcpSocketLink[id=1,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:29.821] TcpSocketLink[id=8,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:29.867] TcpSocketLink[id=2,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:29.961] TcpSocketLink[id=5,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:29.977] TcpSocketLink[id=4,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:31.477] TcpSocketLink[id=7,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:36.430] TcpSocketLink[id=6,historiatv_r4] failed keepalive (select)
[2010/06/30 15:06:40.008] TcpSocketLink[id=3,historiatv_r4] failed keepalive (select)
 
(0004700)
briandeng
08-04-10 07:16

fyi.. I haven't seen these errors since upgrading to 4.0.9. Perhaps this has been fixed in that release?
 
(0004701)
phcollard
08-04-10 07:42

Alex from Caucho told me this issue is NOT fixed in 4.0.9
 

- Issue History
Date Modified Username Field Change
06-02-10 09:20 alex New Issue
06-02-10 09:45 briandeng File Added: server.log
06-02-10 10:42 briandeng File Added: server.log.finer.gz
06-02-10 10:42 briandeng Note Added: 0004648
06-02-10 12:36 phcollard Note Added: 0004649
07-01-10 16:04 briandeng Issue Monitored: briandeng
07-12-10 08:09 phcollard Issue Monitored: phcollard
08-04-10 07:16 briandeng Note Added: 0004700
08-04-10 07:42 phcollard Note Added: 0004701
01-14-11 12:48 ferg Assigned To  => ferg
01-14-11 12:48 ferg Status new => closed
01-14-11 12:48 ferg Resolution open => fixed
01-14-11 12:48 ferg Fixed in Version  => 4.0.14


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
41 total queries executed.
31 unique queries executed.
Powered by Mantis Bugtracker