Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003965 [Resin] minor always 03-24-10 12:35 03-03-10 15:47
Reporter emil View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.10
Summary 0003965: cluster imported as server with resin:import
Description (rep by fifth-aeon)


I'm working on streamlining some of our resin config and having some trouble figuring out how to use resin:import properly. We're using Resin 3.1.9.

In a nutshell, we have a few clusters running, which share a lot of common configuration. I'm trying to do this:

<cluster id="a">

<!-- includes the app-default for default web-app behavior -->
<resin:import path="${resin.root}/conf/server-default.xml"/>

<server id="A" address="xx.xx.xx.xx" port="6800">
... server specific stuff
</server>

.. more servers
</cluster>

... more clusters that also import my server-default.xml file

My server-default.xml file looks like this:

<cluster xmlns="http://caucho.com/ns/resin" [^]
xmlns:resin="http://caucho.com/ns/resin/core"> [^]

<server-default>
<!--
- The JVM arguments
-->
<jvm-arg>-d64</jvm-arg>
<jvm-arg>-XX:+DisableExplicitGC</jvm-arg>
<jvm-arg>-server</jvm-arg>
<jvm-arg>-XX:+UseConcMarkSweepGC</jvm-arg>
<jvm-arg>-XX:+UseParNewGC</jvm-arg>
<jvm-arg>-XX:+CMSIncrementalMode</jvm-arg>
<jvm-arg>-XX:+CMSIncrementalPacing</jvm-arg>
<jvm-arg>-XX:NewRatio=2</jvm-arg>
<jvm-arg>-XX:MaxPermSize=384m</jvm-arg>
<jvm-arg>-Dcom.sun.management.jmxremote</jvm-arg>
<jvm-arg>-Dcatalina.home=${resin.root}</jvm-arg>

.. more server-default stuff

</server-default>
</cluster>

I'm getting this error in the server log:

'server-default' is an unknown property of 'com.caucho.server.cluster.Server'.

Any thoughts on what I'm doing wrong here?

Much thanks!
Additional Information Reproduced on 3.1.9 and 3.1.10:

/home/emil/support/resin-pro-3.1.10/conf/server-default.xml:4: 'server-default' is an unknown property of 'com.caucho.server.cluster.Server'.

2: xmlns:resin="http://caucho.com/ns/resin/core"> [^]
3:
4: <server-default>
5: <!-- The http port -->
6: <http address="*" port="8080"/>

Appears to work in Resin 4.0.5
Attached Files

- Relationships

- Notes
(0004506)
ferg
03-03-10 15:47

server/2d01

The main issue is that <resin:import> isn't expanded immediately in 3.1 (it is expanded immediately in 4.0).
 

- Issue History
Date Modified Username Field Change
03-24-10 12:35 emil New Issue
03-03-10 15:47 ferg Note Added: 0004506
03-03-10 15:47 ferg Assigned To  => ferg
03-03-10 15:47 ferg Status new => closed
03-03-10 15:47 ferg Resolution open => fixed
03-03-10 15:47 ferg Fixed in Version  => 4.0.6


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker