Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003848 [Resin] crash always 01-14-10 06:07 03-02-10 16:53
Reporter zenant View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.7
Summary 0003848: resin in a deadlock on com.caucho.loader.EnvironmentClassLoader
Description On production site we just had all hmux thread deadlocked on one instance of com.caucho.loader.EnvironmentClassLoader.
This is a part of thread dump. Please let me know if you need more deatils from the dump.

Level Name Group CPU Time [ms] State Waiting On Owned By Owned Monitors Priority Start Time Thread Id
1 http-127.0.0.1:80-2 main 5300 blocked com.caucho.loader.ClassEntry@1346486529 747138112 5 5 2010-01-13 21:04:13 1745510705
1 ReportWorkerThread[1801a2g0000icamie79g000000]: slow fast unknown main 6630 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 - 4 2010-01-13 22:11:59 382503307
1 PS Agent Scheduler Consumer[0] main 5160 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 - 5 2010-01-13 21:34:26 1397517209
1 PS Agent Runner: 0 main 185320 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 2 5 2010-01-13 21:08:53 511635087
1 PS Agent Monitor main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 - 5 2010-01-13 21:34:26 1324811909
1 http-127.0.0.1:80-26 main 4170 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 4 5 2010-01-13 21:04:13 747138112
1 hmux-10.0.21.10:6802-87 main 20 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 08:02:10 107780931
1 hmux-10.0.21.10:6802-77 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 06:34:51 1089374285
1 hmux-10.0.21.10:6802-68 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 07:42:28 1217386988
1 hmux-10.0.21.10:6802-65 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 06:58:57 541515094
1 hmux-10.0.21.10:6802-61 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 2 5 2010-01-14 02:56:58 1461526742
1 hmux-10.0.21.10:6802-59 main 10 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 05:32:28 2069132692
1 hmux-10.0.21.10:6802-171 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 08:07:14 370178277
1 hmux-10.0.21.10:6802-168 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 07:52:30 1638304546
1 hmux-10.0.21.10:6802-167 main 270 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 05:57:27 1415921416
1 hmux-10.0.21.10:6802-165 main 10 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 06:54:56 2097229470
1 hmux-10.0.21.10:6802-164 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 06:48:54 1014958559
1 hmux-10.0.21.10:6802-162 main 70 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 06:35:52 1739246706
1 hmux-10.0.21.10:6802-158 main 80 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 06:40:53 1981366117
1 hmux-10.0.21.10:6802-157 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 05:57:27 861362450
1 hmux-10.0.21.10:6802-156 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 07:52:30 1575246794
1 hmux-10.0.21.10:6802-154 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 07:42:28 680887895
1 hmux-10.0.21.10:6802-152 main 700 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 05:32:28 1322756033
1 hmux-10.0.21.10:6802-151 main 9540 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-13 21:04:28 147610680
1 hmux-10.0.21.10:6802-148 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 06:28:29 74641099
1 hmux-10.0.21.10:6802-147 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 06:13:47 319384505
1 hmux-10.0.21.10:6802-146 main 10 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 06:35:52 370033260
1 hmux-10.0.21.10:6802-145 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 06:46:54 971957053
1 hmux-10.0.21.10:6802-142 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 07:59:19 1299221522
1 hmux-10.0.21.10:6802-141 main 220 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 05:26:03 1794037666
1 hmux-10.0.21.10:6802-140 main 30 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 06:28:30 1385571362
1 hmux-10.0.21.10:6802-139 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 07:42:28 604068026
1 hmux-10.0.21.10:6802-136 main 50 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 06:18:48 1607429586
1 hmux-10.0.21.10:6802-134 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 07:24:05 1688861483
1 hmux-10.0.21.10:6802-125 main 160 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 05:32:28 1900273841
1 hmux-10.0.21.10:6802-124 main 20 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 07:54:20 1575329794
1 hmux-10.0.21.10:6802-122 main 10 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 07:00:57 508437962
1 hmux-10.0.21.10:6802-117 main 10 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 07:23:25 109988836
1 hmux-10.0.21.10:6802-111 main 0 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-14 06:28:29 1270308904
1 hmux-10.0.21.10:6802-108 main 250 blocked com.caucho.loader.EnvironmentClassLoader@660662434 1745510705 1 5 2010-01-13 22:55:04 395217923

Additional Information
Attached Files

- Relationships

- Notes
(0004384)
ferg
01-14-10 08:43

Thanks for the bug report. That thread dump looks like a bug that we've fixed in 4.0.x. I believe we've also fixed it in 3.1.9, but I'd need to double-check that code.
 

- Issue History
Date Modified Username Field Change
01-14-10 06:07 zenant New Issue
01-14-10 08:43 ferg Note Added: 0004384
03-02-10 16:53 ferg Assigned To  => ferg
03-02-10 16:53 ferg Status new => closed
03-02-10 16:53 ferg Resolution open => fixed
03-02-10 16:53 ferg Fixed in Version  => 4.0.6


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker