Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003832 [Resin] minor always 12-02-09 05:12 03-03-10 16:50
Reporter anton_kg View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.2
Summary 0003832: websocket does not work with <POLICY-FILE-REQUEST/>
Description Hi, I'm trying to run websocket protocol with unsupported browsers via web_socket.js
(http://github.com/gimite/web-socket-js/raw/master/web_socket.js) [^]
They use adobe flash for that to workaround the implementation and as a part of flash protocol it should send policy request.
I've tried to add
<protocol port="8080" type="com.caucho.protocols.flash.SocketPolicyProtocol">
  <init>
    <socket-policy-file>/socketpolicy.xml</socket-policy-file>
  </init>
</protocol>
section but it didn't work.

Do you think it make sense to fix it even it's not a part of the specification?

Thank you.
Additional Information The preferred configuration (CanDI-based) now looks like:

<server id="">
<listen address="*" port="8080">
  <flash:SocketPolicyProtocol
     xmlns:flash="urn:java:com.caucho.protocols.flash">
    <policy-file>/test.policy</policy-file>
  </flash:SocketPolicyProtocol>
</listen>
</server>
Attached Files

- Relationships

- Notes
(0004510)
ferg
03-03-10 16:50

server/3212
 

- Issue History
Date Modified Username Field Change
12-02-09 05:12 anton_kg New Issue
03-03-10 16:50 ferg Note Added: 0004510
03-03-10 16:50 ferg Assigned To  => ferg
03-03-10 16:50 ferg Status new => closed
03-03-10 16:50 ferg Resolution open => fixed
03-03-10 16:50 ferg Fixed in Version  => 4.0.6
03-03-10 16:50 ferg Additional Information Updated


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
30 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker