Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003699 [Resin] minor always 09-28-09 09:55 10-02-09 18:36
Reporter daniel_larsson View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.0.28
Summary 0003699: Faulty code generated for JSP pages under some circumstances
Description I'm not sure how to minimally produce this, but I have a tagfile using a custom taglib, and I'm getting java compile errors in the generated java code. The problem is similar to the one reported in bug 0001037.

The problem is the generated code includes a reference to "_jspBody", which is a private member, and not accessible by the generated class.

In the source modules/resin/src/com/caucho/jsp/java/JspNode.java, generateFragment contains the code:

    if (_gen instanceof JavaTagGenerator) {
      JavaTagGenerator tagGen = (JavaTagGenerator) _gen;
      
      if (tagGen.isStaticDoTag()) // jsp/1025
    cb.append(", _jspBody");
      else
    cb.append(", getJspBody()");
    }
    else
      cb.append(", null");

but modules/resin/src/com/caucho/jsp/java/JspFragmentNode.java, generateValue says:

    if (_gen instanceof JavaTagGenerator)
      cb.append(", _jspBody");
    else
      cb.append(", null");

Changing the latter into the former fixes the problem.

Additional Information This problem seems to be present in 3.0.28, 3.1.9 and 4.0.1
Attached Files

- Relationships

- Notes
(0004275)
alex
10-02-09 18:36

jsp/100g.qa
 

- Issue History
Date Modified Username Field Change
09-28-09 09:55 daniel_larsson New Issue
09-28-09 09:56 daniel_larsson Issue Monitored: daniel_larsson
10-02-09 18:36 alex Status new => closed
10-02-09 18:36 alex Note Added: 0004275
10-02-09 18:36 alex Resolution open => fixed
10-02-09 18:36 alex Fixed in Version  => 4.0.2


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker