Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003584 [Resin] minor always 06-27-09 20:06 07-02-09 15:29
Reporter ferg View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0003584: JSP slow compilation
Description (rep by Rick Mann)


Use of JSP-2.0 style tag definitions causes the calling page to get
recompiled each and every time it's called.

Adding a simple-loader to point to WEB-INF/root fixes this, because it
avoids the ClassNotFoundException resin gets when attempting to load
the class for the tag (how it manages to work even though it can't
load the class escapes me).

Unfortunately that seems to introduce a dependency check on that
directory that causes resin to reload the context every time a JSP is
changed.

This strikes me as a fairly serious problem, particularly because
Resin leaks terribly when it reloads the context, and so I have to
shut it down and restart it.

Additional Information
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
06-27-09 20:06 ferg New Issue
07-02-09 15:29 ferg Assigned To  => ferg
07-02-09 15:29 ferg Status new => closed
07-02-09 15:29 ferg Resolution open => fixed
07-02-09 15:29 ferg Fixed in Version  => 4.0.1


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
26 total queries executed.
24 unique queries executed.
Powered by Mantis Bugtracker