Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003539 [Resin] minor always 05-02-09 18:08 06-01-09 15:34
Reporter voodude View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 4.0.0
Summary 0003539: Remoting documentation is out of date
Description The remoting documentation makes reference to <remote-client class="blahblah" ... but the attribute has changed to <remote-client interface="blahblah" ...

Also, it seems that there are a bunch of interesting options for <remote-client> that aren't documented.

Also, the injection annotations are the older webbeans style (ie @In).
Additional Information
Attached Files

- Relationships

- Notes
(0004046)
ferg
06-01-09 15:34

The remoting is a bit complicated because the configuration was not ready for 4.0.0. The new configuration uses class annotations for the remoting protocol (configured with CanDI in XML, so the annotations are not actually in the Java code.)

 

- Issue History
Date Modified Username Field Change
05-02-09 18:08 voodude New Issue
05-02-09 18:08 voodude Issue Monitored: voodude
06-01-09 15:34 ferg Note Added: 0004046
06-01-09 15:34 ferg Assigned To  => ferg
06-01-09 15:34 ferg Status new => closed
06-01-09 15:34 ferg Resolution open => fixed
06-01-09 15:34 ferg Fixed in Version  => 4.0.1


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
30 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker