Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003426 [Resin] trivial always 03-02-09 18:33 04-23-09 09:25
Reporter tripleyew View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.1.8
Summary 0003426: resin-maven-plugin-3.1.8.jar is broken
Description There are versioning problems with the resin-maven-plugin-3.1.8.jar
When using Apache Maven 2.1.0:

Plugin 'com.caucho:resin-maven-plugin:3.1.8' has an invalid descriptor:
1) Plugin's descriptor contains the wrong version: 3.1-SNAPSHOT

The file META-INF/maven/plugin.xml
has
  <version>3.1-SNAPSHOT</version>
should be
  <version>3.1.8</version>

Also, it has a dependency on resin SNAPSHOT-3.1.
This should be 3.1.8

The file META-INF/maven/com.caucho/resin-maven-plugin/pom.xml
has
  <version>3.1.7</version>
should be
  <version>3.1.8</version>

(same for the dependency on resin)


Additional Information I believe all releases of this plugin suffers from these problems.

There may be some hardcoding involved, because
resin-maven-plugin-3.2.1.jar also mentions 3.1 which is completely wrong.
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
03-02-09 18:33 tripleyew New Issue
04-23-09 09:25 emil Status new => closed
04-23-09 09:25 emil Resolution open => fixed
04-23-09 09:25 emil Fixed in Version  => 4.0.0
06-02-09 13:33 tripleyew Issue Monitored: tripleyew


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
28 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker