Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003424 [Resin] minor always 03-02-09 09:29 08-25-09 19:17
Reporter ferg View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.2.1
Summary 0003424: Amber query limits
Description (rep by Riccardo Cohen)
When I execute this :

Query hqr=m_manager.createQuery("select h from Adluser h order by h.id");
hqr.setFirstResult(numstart);
hqr.setMaxResults(numcnt);

I have the good result (starts at numstart, and get numcnt items)
But when I do not set the limits :

Query hqr=m_manager.createQuery("select h from Adluser h order by h.id");

I have only 32 results whatever you have in the database.

This appeared only from 3,2,1 because I do not have this problem with
3.2.0.

Am I doing something wrong ?
Thanks for any help.

PS: I went to 3.2.1 because I had problems with scheduled-task in 3,2.0

Additional Information
Attached Files

- Relationships

- Notes
(0004159)
ferg
08-25-09 19:17

jpa/1436
 

- Issue History
Date Modified Username Field Change
03-02-09 09:29 ferg New Issue
08-25-09 19:17 ferg Note Added: 0004159
08-25-09 19:17 ferg Assigned To  => ferg
08-25-09 19:17 ferg Status new => closed
08-25-09 19:17 ferg Resolution open => fixed
08-25-09 19:17 ferg Fixed in Version  => 4.0.2


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
28 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker