Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003305 [Quercus] block always 01-01-09 23:17 02-09-09 07:00
Reporter mingfai View Status public  
Assigned To nam
Priority normal Resolution fixed  
Status closed   Product Version 3.2.1
Summary 0003305: Dukuwiki-rc2009-01-26 cannot access the first page
Description java.lang.UnsupportedOperationException: openWrite:com.caucho.vfs.NotFoundPath
        at com.caucho.vfs.Path.openWriteImpl(Path.java:1389)
        at com.caucho.vfs.Path.openWrite(Path.java:1088)
        at com.caucho.quercus.lib.file.FileModule.copy(FileModule.java:322)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
sorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at com.caucho.quercus.module.StaticFunction.invoke(StaticFunction.java:1
29)
        at com.caucho.quercus.env.JavaInvoker.callMethod(JavaInvoker.java:618)
        at com.caucho.quercus.env.JavaInvoker.call(JavaInvoker.java:553)
        at com.caucho.quercus.expr.FunctionExpr.evalImpl(FunctionExpr.java:182)
        at com.caucho.quercus.expr.FunctionExpr.eval(FunctionExpr.java:126)
        at com.caucho.quercus.program.ExprStatement.execute(ExprStatement.java:6
4)
        at com.caucho.quercus.program.BlockStatement.execute(BlockStatement.java
:105)
        at com.caucho.quercus.program.Function.callImpl(Function.java:363)
        at com.caucho.quercus.program.Function.call(Function.java:292)
        at com.caucho.quercus.expr.FunctionExpr.evalImpl(FunctionExpr.java:182)
        at com.caucho.quercus.expr.FunctionExpr.eval(FunctionExpr.java:126)
        at com.caucho.quercus.program.ExprStatement.execute(ExprStatement.java:6
4)
        at com.caucho.quercus.program.BlockStatement.execute(BlockStatement.java
:105)
        at com.caucho.quercus.program.IfStatement.execute(IfStatement.java:81)
        at com.caucho.quercus.program.BlockStatement.execute(BlockStatement.java
:105)
        at com.caucho.quercus.program.QuercusProgram.execute(QuercusProgram.java
:327)
        at com.caucho.quercus.page.InterpretedPage.execute(InterpretedPage.java:
71)
        at com.caucho.quercus.page.QuercusPage.executeTop(QuercusPage.java:119)
        at com.caucho.quercus.servlet.QuercusServletImpl.service(QuercusServletI
mpl.java:167)
        at com.caucho.quercus.servlet.QuercusServlet.service(QuercusServlet.java
:407)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
Additional Information
Attached Files

- Relationships

- Notes
(0003816)
nam
02-09-09 07:00

php/600b

Fixed for 4.0.

Dokuwiki passes in a path of the form "C:abc/def". This fails because of the missing slash right after the colon.
 

- Issue History
Date Modified Username Field Change
01-01-09 23:17 mingfai New Issue
02-09-09 06:58 nam Status new => assigned
02-09-09 06:58 nam Assigned To  => nam
02-09-09 07:00 nam Status assigned => closed
02-09-09 07:00 nam Note Added: 0003816
02-09-09 07:00 nam Resolution open => fixed
02-09-09 07:00 nam Fixed in Version  => 4.0.0


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker