Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003294 [Resin] minor always 01-23-09 09:18 10-01-09 16:02
Reporter ferg View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.2.1
Summary 0003294: comet timeout issues
Description (rep by Caleb Richardson)
We're considering using Resin's comet implementation in an HTTP idle
scenario (probably 30 minute wait period), where an HTTP client creates
a connection and then waits up to 30 minutes for a response.

I understand that one of the idle connections takes up a socket on the
server but not a thread. However, does this mean that the server will
never receive a close event from the client (since nothing is blocking
on read)? If this is the case, then any background worker threads
(spawned by me) responsible for calling CometController#wake will
continue to work on behalf of that connection until the wait period is up.

Additional Information
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
01-23-09 09:18 ferg New Issue
10-01-09 16:02 ferg Assigned To  => ferg
10-01-09 16:02 ferg Status new => closed
10-01-09 16:02 ferg Resolution open => fixed
10-01-09 16:02 ferg Fixed in Version  => 4.0.2


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
26 total queries executed.
24 unique queries executed.
Powered by Mantis Bugtracker