Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003229 [Resin] minor always 01-08-09 16:42 03-03-10 12:50
Reporter ferg View Status public  
Assigned To ferg
Priority urgent Resolution fixed  
Status closed   Product Version 3.0.25
Summary 0003229: log file formatting
Description (rep by Jamison Novak)

I'm struggling with some log formatting in Resin 3.0 and I'm hoping you can point me in the right direction. I've been unsuccessful in finding anything about this in documentation.
 
We are currently logging Java exceptions (or stack traces/dumps, if you prefer) and, since they can be very long and typically multi-line, Resin puts a timestamp in front of each part of the exception even though it's all one big error. Is there any way to prevent that from happening and to only have a timestamp on the first part of it? For example:
 
Bad:
[01/08/09:08:16:25] java.lang.NullPointerException
[01/08/09:08:16:25] at com.foo.agent.action.pkg.shared.booking.ServiceAssignmentAction.doBookingWork(Unknown Source)
[01/08/09:08:16:25] at com.foo.agent.action.pkg.shared.booking.BookingAction.doPkgProcessWork(Unknown Source)
[01/08/09:08:16:25] at com.foo.agent.action.pkg.PkgProcessAction.doPkgWork(Unknown Source)
[ ... ]
 
Good:
 
[01/08/09:08:16:25] java.lang.NullPointerException
                                at com.foo.agent.action.pkg.shared.booking.ServiceAssignmentAction.doBookingWork(Unknown Source)
                                at com.foo.agent.action.pkg.shared.booking.BookingAction.doPkgProcessWork(Unknown Source)
                                at com.foo.agent.action.pkg.PkgProcessAction.doPkgWork(Unknown Source)
[...]
 
 
We are attempting to import our Resin logs into a centralized log system and, because of that time stamping, it is interpreting each of those lines from a single exception as unrelated events. We are looking for a way to get it to be treated as a single log event.
 
Any thoughts? I'm really at a loss.
 
Additional Information
Attached Files

- Relationships

- Notes
(0003907)
ferg
03-19-09 10:22

server/02d3
 
(0004325)
alex
12-08-09 18:09

<log-handler> prints time stamp for each line using default resin.xml in 4.0.2
 
(0004501)
ferg
03-03-10 12:50

env/02d4
 

- Issue History
Date Modified Username Field Change
01-08-09 16:42 ferg New Issue
03-19-09 10:22 ferg Note Added: 0003907
03-19-09 10:22 ferg Assigned To  => ferg
03-19-09 10:22 ferg Status new => closed
03-19-09 10:22 ferg Resolution open => fixed
03-19-09 10:22 ferg Fixed in Version  => 4.0.0
12-08-09 18:09 alex Status closed => feedback
12-08-09 18:09 alex Resolution fixed => reopened
12-08-09 18:09 alex Note Added: 0004325
12-08-09 18:09 alex Note Added: 0004326
12-08-09 18:10 alex Note Deleted: 0004326
03-03-10 12:50 ferg Note Added: 0004501
03-03-10 12:50 ferg Status feedback => closed
03-03-10 12:50 ferg Resolution reopened => fixed
03-03-10 12:50 ferg Fixed in Version 4.0.0 => 4.0.6


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
35 total queries executed.
28 unique queries executed.
Powered by Mantis Bugtracker