Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002963 [Resin] crash always 09-24-08 13:10 07-01-09 16:24
Reporter thompsonm View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.8
Summary 0002963: Memory leak in LRU Cache related to URI and comet implementation
Description The system leaks memory that eventually brings down the sever because of byte[]s building up in _invocationCache of com.caucho.server.cluster.Server. Also found in com.caucho.server.http.InvocationKey._uri and all related to the URI that is using during long poll in the comet implementation.
Additional Information A heap dump of 43MB in BZ2 format can be provided if necessary.
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
09-24-08 13:10 thompsonm New Issue
03-17-09 08:21 jhobeck Issue Monitored: jhobeck
07-01-09 16:24 ferg Assigned To  => ferg
07-01-09 16:24 ferg Status new => closed
07-01-09 16:24 ferg Resolution open => fixed
07-01-09 16:24 ferg Fixed in Version  => 4.0.1


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker