Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002885 [Resin] trivial always 08-03-08 12:36 09-04-08 14:03
Reporter iRideSnow View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.2.0
Summary 0002885: 3.2.0 Pro Creates .git Directory
Description When 3.2.0 Pro is started, it creates a .git in the resin.home folder.

I guess that means you guys are using Git for source control?

Here's the directory listing:

/resin/.git/branches
/resin/.git/objects
/resin/.git/refs
/resin/.git/tmp
/resin/.git/HEAD


Additional Information I don't know if this is limited to the Pro version or not.
Attached Files

- Relationships

- Notes
(0003385)
ferg
09-04-08 13:59

That's actually normal because it's used for Resin's deployment capabilities. However, we should only create those directories if the deployment is being used.
 
(0003386)
ferg
09-04-08 14:03

Change behavior to create .git only if the deploy is actually used.
 

- Issue History
Date Modified Username Field Change
08-03-08 12:36 iRideSnow New Issue
09-04-08 13:59 ferg Note Added: 0003385
09-04-08 14:03 ferg Note Added: 0003386
09-04-08 14:03 ferg Assigned To  => ferg
09-04-08 14:03 ferg Status new => closed
09-04-08 14:03 ferg Resolution open => fixed
09-04-08 14:03 ferg Fixed in Version  => 3.2.1


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker