Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000288 [Resin] minor always 06-28-05 00:00 11-30-05 14:43
Reporter jkriesten View Status public  
Assigned To
Priority urgent Resolution fixed  
Status closed   Product Version 3.0.13
Summary 0000288: jdk-1_5_0_04 contains incompatible javax.managment
Description RSN-327
Under the new jdk update from sun resin refuses to start:
 
---8<---
Specification version 1.5 of package javax.management, Java Platform API Specification, version 1.5 is not compatible with Resin 3.0.13. Resin 3.0.13 requires version 1.2.
---8<---

Version jdk-1_5_0_03 works fine though.
Additional Information SuSE Linux 9.3
Sun JDK 1.5.0.04
Attached Files

- Relationships

- Notes
(0000323)
gohanlon
06-28-05 00:00

Examining the release notes for Update 4 I found that following change had been made:

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6198522 [^]

The "Specification-Version" entry in the manifest file for "rt.jar" has had its value changed from "1.4" to "1.5" in the latest update. I changed the value back to "1.4" and the error went away.

Is a custom class loader being used, keying off of this runtime property to load the "older" JMX classes?
 

- Issue History
Date Modified Username Field Change
06-28-05 00:00 jkriesten New Issue
11-30-05 00:00 administrator Fixed in Version  => 3.0.14
11-30-05 14:43 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
30 total queries executed.
28 unique queries executed.
Powered by Mantis Bugtracker