Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000284 [Resin] minor always 06-24-05 00:00 12-06-05 10:27
Reporter foolfish View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 2.1.x
Summary 0000284: problem fro "Properties.loadFromXML(InputStream)" under 2.1.16 resin
Description RSN-323
i use the properties.loadFromXML(InputStream) can load the XML document to
a properties(Properties class),
bug i use this under resin 2.1.x is error.(null exception)

i think because resin overloading JDK parse XML Class.

please try it.

my english so pool.sorry.


code:
---------------------------------------
//use storeToXML() save a XML file,and run ...:

<%
Properties _props=new Properties();
FileInputStream fis = new FileInputStream("/data/resin_vhost/foolfish/testclass/rhyme.xml");
_props.loadFromXML(fis);
_props.list(System.out);
%>
Additional Information any system
jdk1.5.0.00-jdk1.5.0.03
Attached Files

- Relationships

- Notes
(0000512)
ferg
12-06-05 10:27

server/1i00
 

- Issue History
Date Modified Username Field Change
06-24-05 00:00 foolfish New Issue
12-06-05 10:27 ferg Status acknowledged => closed
12-06-05 10:27 ferg Note Added: 0000512
12-06-05 10:27 ferg Resolution open => fixed
12-06-05 10:27 ferg Fixed in Version  => 3.0.16


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker