Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000282 [Resin] minor always 06-23-05 00:00 11-30-05 14:43
Reporter quotemedia View Status public  
Assigned To
Priority urgent Resolution fixed  
Status closed   Product Version 3.0.13
Summary 0000282: resin-pro-3.0.13+ & java 1.4.2: java.lang.UnsupportedClassVersionError: javax/ejb/EntityManager (Unsupported
Description RSN-321
t appears that more and more java 1.5 code is sneaking into resin 3.

resin-pro-3.0.13 and resin-pro-3.0.s051615 give the following error using 1.4.2 on both linux and os x:

java.lang.UnsupportedClassVersionError: javax/ejb/EntityManager (Unsupported
major.minor version 49.0)

this error is known to indicate 1.5 compile code trying to run under a 1.4 jvm.

resin 3.0.13 still starts up the webapp and everything seems to work, at least for us. however, resin 3.0.s050615 kills the webapp and doesn't load it at all, so i am assuming that it is even more tied to java 1.5.

both of these versions start up the webapp with 1.5 (aside from other errors which I have submitted as bugs).
Additional Information resin-pro-3.0.13 and resin-pro-3.0.s050615, os x 10.4 & linux, java 1.4.2_07
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
06-23-05 00:00 quotemedia New Issue
11-30-05 00:00 administrator Fixed in Version  => 3.0.14
11-30-05 14:43 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
28 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker