Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000269 [Resin] minor always 06-16-05 00:00 11-30-05 14:43
Reporter ferg View Status public  
Assigned To
Priority urgent Resolution fixed  
Status closed   Product Version 2.1.x
Summary 0000269: 2.1.16 mod_caucho under load
Description RSN-292
(rep by Matt Brown)


This morning we tried to upgrade 4 of 25 Resin instances from 2.1.10 to
2.1.16. First we updated mod_caucho on the Apache instances, then we
upgraded the 4 Resin instances. Almost immediately we noticed a large
number of 503 errors being returned by Apache. After reverting
everything to 2.1.10, we did some testing. The 503 errors only occur for
requests for resources handled by Resin like JSPs. It also appears that
the 503 errors only happen when Apache is under noticeable load. A
virtually idle Apache does not exhibit this problem.

The only thing in the Apache log about the error was stuff like this in
the access log:

172.18.180.24 - - [16/Jun/2005:12:28:08 -0500] "GET
/index.jsp?pageName=hotSearch HTTP/1.1" 503 323 "-" "Java/1.4.2_08"

There was nothing in the access log or /var/log/messages.

The error displayed to the user appears to come from Apache:

Service Temporarily Unavailable
The server is temporarily unable to service your request due to
maintenance downtime or capacity problems. Please try again later.

In a test environment, we were unable to recreate the problem with
mod_caucho 2.1.10 and Resin 2.1.10. By simply switching mod_caucho and
Resin to 2.1.16, we were able to reproduce the problem using the
attached test case (Test.java).

The web sever is Linux and Apache:

    [root@amsterdam apache]# uname -a
    Linux amsterdam.travelnow.com 2.4.21-4.ELsmp 0000001 SMP Fri Oct 3
17:52:56 EDT 2003 i686 i686 i386 GNU/Linux

    [dev@amsterdam dev]$ /usr/sbin/httpd -V
    Server version: Apache/2.0.48
    Server built: Nov 19 2003 08:36:12
    Server's Module Magic Number: 20020903:4
    Architecture: 32-bit
    Server compiled with....
     -D APACHE_MPM_DIR="server/mpm/prefork"
     -D APR_HAS_SENDFILE
     -D APR_HAS_MMAP
     -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
     -D APR_USE_SYSVSEM_SERIALIZE
     -D APR_USE_PTHREAD_SERIALIZE
     -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
     -D APR_HAS_OTHER_CHILD
     -D AP_HAVE_RELIABLE_PIPED_LOGS
     -D HTTPD_ROOT="/etc/httpd"
     -D SUEXEC_BIN="/usr/sbin/suexec"
     -D DEFAULT_PIDLOG="logs/httpd.pid"
     -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
     -D DEFAULT_LOCKFILE="logs/accept.lock"
     -D DEFAULT_ERRORLOG="logs/error_log"
     -D AP_TYPES_CONFIG_FILE="conf/mime.types"
     -D SERVER_CONFIG_FILE="conf/httpd.conf"

The server running the Resin instance is also Linux:

    [dev@yazoo foo]$ uname -a
    Linux foo.com 2.6.9-5.ELsmp 0000001 SMP Wed Jan 5 19:30:39
EST 2005 i686 i686 i386 GNU/Linux

The Resin instance runs against JDK 1.4.2_06-b03.

It basically seems like mod_caucho in 2.1.16 has an issue under load.
Are you aware of any issues like this? What additional information can
we provide to get this resolved quickly? We'd really like to pick up
some specific bug fixes in 2.1.16.
Additional Information
Attached Files

- Relationships

- Notes
(0000299)
fatpanda
06-16-05 00:00

Based on further testing, we were able to determine that this problem began with 2.1.14. Resin 2.1.13 does not exhibit this problem.
 
(0000300)
ferg
06-16-05 00:00

Issues with mod_caucho and keepalives resolved in snapshot.
 

- Issue History
Date Modified Username Field Change
06-16-05 00:00 ferg New Issue
11-30-05 00:00 administrator Fixed in Version  => 2.1.x
11-30-05 14:43 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
29 unique queries executed.
Powered by Mantis Bugtracker