Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002671 [Quercus] major always 05-16-08 06:49 05-01-08 10:52
Reporter dberry View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.6
Summary 0002671: BUG #0001497 has reappeared somewhere between 3.1.1 (working) and 3.1.6(Not working)
Description Tried to upgrade from 3.1.1 to 3.1.6, Found a bug that I reported in 3.1.0 has resurfaced

Basically you are assuming that php programmers use only one connection and are caching that connection, yet you allow a person to close the cached connection and then when it is requested again you send back a closed connection to the program.

This test case uses perfectly acceptable php code. php allows you to manage connections. You should too.

Looks like I am going back to 3.1.1
Additional Information I have added my test case below
Attached Files  testAutoCommit.php [^] (1,197 bytes) 05-16-08 06:49

- Relationships

- Notes
(0003110)
ferg
05-01-08 10:52

php/143e
 

- Issue History
Date Modified Username Field Change
05-16-08 06:49 dberry New Issue
05-16-08 06:49 dberry File Added: testAutoCommit.php
05-01-08 10:52 ferg Note Added: 0003110
05-01-08 10:52 ferg Assigned To  => ferg
05-01-08 10:52 ferg Status new => closed
05-01-08 10:52 ferg Resolution open => fixed
05-01-08 10:52 ferg Fixed in Version  => 3.1.7


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker