Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002642 [Resin] major always 04-02-08 07:22 05-09-08 16:31
Reporter markus View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.6
Summary 0002642: Amber / Webbeans problem (initialization order)
Description A webbeans component that references a EJB bean that should be enhanced by Amber the order of initialization causes the webbeans to load first, before Amber enhances the class. The un-enhanced class is thus loaded and resin loads with following exception:

[16:16:15.964] {main} com.caucho.amber.AmberRuntimeException: 'test.TestObject' with classloader EnvironmentClassLoader[web-app:http://localhost:8080/test] [^] is an illegal instance class. The class has not been enhanced as implementing interface com.caucho.amber.entity.Entity.
[16:16:15.964] {main} at com.caucho.amber.type.AbstractEnhancedType.getInstanceClass(AbstractEnhancedType.java:287)
[16:16:15.964] {main} at com.caucho.amber.type.EntityType.getInstanceClass(EntityType.java:201)
[16:16:15.964] {main} at com.caucho.amber.entity.AmberEntityHome.init(AmberEntityHome.java:185)
[16:16:15.964] {main} at com.caucho.amber.manager.AmberPersistenceUnit.initEntityHomes(AmberPersistenceUnit.java:1391)
[16:16:15.964] {main} at com.caucho.amber.manager.AmberContainer.startPersistenceUnits(AmberContainer.java:831)
[16:16:15.964] {main} at com.caucho.amber.manager.AmberContainer.start(AmberContainer.java:567)
[16:16:15.964] {main} at com.caucho.config.j2ee.InjectIntrospector.generatePersistenceContext(InjectIntrospector.java:476)
[16:16:15.964] {main} at com.caucho.config.j2ee.InjectIntrospector.introspect(InjectIntrospector.java:377)
[16:16:15.964] {main} at com.caucho.config.j2ee.InjectIntrospector.introspectInjectImpl(InjectIntrospector.java:210)
[16:16:15.964] {main} at com.caucho.config.j2ee.InjectIntrospector.introspectInject(InjectIntrospector.java:183)
[16:16:15.964] {main} at com.caucho.webbeans.component.ClassComponent.bind(ClassComponent.java:411)
[16:16:15.964] {main} at com.caucho.webbeans.manager.WebBeansContainer.bind(WebBeansContainer.java:1007)
[16:16:15.964] {main} at com.caucho.webbeans.manager.WebBeansContainer.environmentStart(WebBeansContainer.java:1042)
[16:16:15.964] {main} at com.caucho.loader.EnvironmentClassLoader.start(EnvironmentClassLoader.java:583)
[16:16:15.964] {main} at com.caucho.server.webapp.WebApp.start(WebApp.java:1825)
[16:16:15.964] {main} at com.caucho.server.deploy.DeployController.startImpl(DeployController.java:667)
[16:16:15.964] {main} at com.caucho.server.deploy.StartAutoRedeployAutoStrategy.startOnInit(StartAutoRedeployAutoStrategy.java:72)
[16:16:15.964] {main} at com.caucho.server.deploy.DeployController.startOnInit(DeployController.java:549)
[16:16:15.964] {main} at com.caucho.server.deploy.DeployContainer.start(DeployContainer.java:160)
[16:16:15.964] {main} at com.caucho.server.webapp.WebAppContainer.start(WebAppContainer.java:659)
[16:16:15.964] {main} at com.caucho.server.host.Host.start(Host.java:450)
[16:16:15.964] {main} at com.caucho.server.deploy.DeployController.startImpl(DeployController.java:667)
[16:16:15.964] {main} at com.caucho.server.deploy.StartAutoRedeployAutoStrategy.startOnInit(StartAutoRedeployAutoStrategy.java:72)
[16:16:15.964] {main} at com.caucho.server.deploy.DeployController.startOnInit(DeployController.java:549)
[16:16:15.964] {main} at com.caucho.server.deploy.DeployContainer.start(DeployContainer.java:160)
[16:16:15.964] {main} at com.caucho.server.host.HostContainer.start(HostContainer.java:484)
[16:16:15.964] {main} at com.caucho.server.cluster.Server.start(Server.java:1311)
[16:16:15.964] {main} at com.caucho.server.cluster.Cluster.startServer(Cluster.java:710)
[16:16:15.964] {main} at com.caucho.server.cluster.ClusterServer.startServer(ClusterServer.java:542)
[16:16:15.964] {main} at com.caucho.server.resin.Resin.start(Resin.java:703)
[16:16:15.964] {main} at com.caucho.server.resin.Resin.initMain(Resin.java:1157)
[16:16:15.964] {main} at com.caucho.server.resin.Resin.main(Resin.java:1360)

Additional Information Running on MacOS X 10.5.2, Java 1.5.0_13, resin-3.1.s080426. Same problem as with resin-3.1.s080417 (previously reported in bug 2613).
Attached Files  test.tgz [^] (1,458 bytes) 04-02-08 07:22

- Relationships

- Notes
(0003029)
markus
04-02-08 07:24

Duplicate due to extremely slow mantis... Something wrong there as well? ;-)
 
(0003037)
ferg
05-08-08 12:22

Can you mail the test.tgz to ferg@caucho.com? It looks like mantis is corrupting it.
 
(0003041)
ferg
05-09-08 16:31

jpa/0046
 

- Issue History
Date Modified Username Field Change
04-02-08 07:22 markus New Issue
04-02-08 07:22 markus File Added: test.tgz
04-02-08 07:24 markus Note Added: 0003029
04-02-08 07:26 markus Issue Monitored: markus
05-08-08 12:22 ferg Note Added: 0003037
05-09-08 16:31 ferg Note Added: 0003041
05-09-08 16:31 ferg Assigned To  => ferg
05-09-08 16:31 ferg Status new => closed
05-09-08 16:31 ferg Resolution open => fixed
05-09-08 16:31 ferg Fixed in Version  => 3.1.7


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
35 total queries executed.
28 unique queries executed.
Powered by Mantis Bugtracker