Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002638 [Resin] major always 04-01-08 17:52 05-12-08 14:20
Reporter remilon View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.5
Summary 0002638: HttpProxyServlet does not add X-Forwarded-For header
Description We are attempting to use HttpProxyServlet to send traffic to a legacy backend server. However, since all requests come from HttpProxyServlet, the backend server can't properly view the client's IP address, which it needs to be able to do. Most proxies pass the original client's IP address in an X-Forwarded-For header, as described here: http://en.wikipedia.org/wiki/X-Forwarded-For. [^] However, HttpProxyServlet is not doing this or any similar mechanism that we can see.
Additional Information
Attached Files

- Relationships

- Notes
(0003048)
ferg
05-12-08 14:20

server/196d
 

- Issue History
Date Modified Username Field Change
04-01-08 17:52 remilon New Issue
04-02-08 11:54 remilon Issue Monitored: remilon
05-12-08 14:20 ferg Note Added: 0003048
05-12-08 14:20 ferg Assigned To  => ferg
05-12-08 14:20 ferg Status new => closed
05-12-08 14:20 ferg Resolution open => fixed
05-12-08 14:20 ferg Fixed in Version  => 3.1.7


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
30 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker