Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002610 [Resin] minor always 04-19-08 11:43 06-09-08 12:09
Reporter ferg View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.5
Summary 0002610: index page blanks
Description (rep by Shane Cruz)

We are using Resin Pro 3.0.24 and have noticed an intermittent problem that is rather weird. After the JVM has been running for a few days, we some times see the case where HTTP requests for certain files return a blank HTML page such as:
 
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=windows-1252"></HEAD>
<BODY></BODY></HTML>
 
This seems to happen mostly with welcome files (index.html), and we see behavior such as:
 
http://www.mydomain.com/mydirectory [^] works fine
http://www.mydomain.com/mydirectory/ [^] returns this blank HTML page
http://www.mydomain.com/mydirectory/index.html [^] --> returns the blank HTML page as well
http://mydomain.com/mydirectory/ [^] works fine
 
We run a Resin cluster and the weird part is that one JVM will return the blank page while the other ones work fine. When it happens, it seems to affect a lot of pages at once, but only on the one JVM. Restarting that JVM immediately fixes the problem? at least for a few days.
 
Our welcome file list (in app-default.xml) looks normal:
 
  <welcome-file-list>
    <welcome-file>index.html</welcome-file>
    <welcome-file>index.htm</welcome-file>
    <welcome-file>index.jsp</welcome-file>
    <welcome-file>index.php</welcome-file>
  </welcome-file-list>
 
We are caching pages (in resin.conf):
 
    <resin:if test="${isResinProfessional}">
      <cache path="cache" memory-size="10M"/>
    </resin:if>
 
I don?t want to turn on full debug logging because this happens in our production environment but only after the JVM has been running for several days. I would prefer not to slow down the server for a long time with the extra logging.
 
Additional Information
Attached Files

- Relationships

- Notes
(0003153)
ferg
06-09-08 12:09

server/2h04
 

- Issue History
Date Modified Username Field Change
04-19-08 11:43 ferg New Issue
06-09-08 12:09 ferg Note Added: 0003153
06-09-08 12:09 ferg Assigned To  => ferg
06-09-08 12:09 ferg Status new => closed
06-09-08 12:09 ferg Resolution open => fixed
06-09-08 12:09 ferg Fixed in Version  => 3.1.7


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
28 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker