Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002464 [Resin] major always 02-28-08 10:58 03-20-08 14:58
Reporter zdavis View Status public  
Assigned To ferg
Priority urgent Resolution fixed  
Status closed   Product Version 3.1.5
Summary 0002464: rewrite-dispatch duplicates query parameters
Description When using rewrite-dispatch to forward a request, the query string parameters get duplicated. For example:

<rewrite-dispatch>
    <forward regexp="^/s/(.*)" target="/$1" />
</rewrite-dispatch>

www.server.com/s/test.jsp?foo=bar will get rewritten to www.server.com/test.jsp?foo=bar&foo=bar.

The same outcome occurs using rewrite-filter in version 3.0.24.
Additional Information
Attached Files  index.jsp [^] (492 bytes) 03-06-08 09:59
 web.xml [^] (564 bytes) 03-06-08 09:59

- Relationships

- Notes
(0002817)
ferg
03-05-08 09:36

unable to reproduce - server/1kn{0,1}

Can you attach a simple JSP which duplicates the issue? I'm just seeing the expected behavior here.
 
(0002833)
zdavis
03-06-08 10:02

Following are the requests and corresponding outputs in the standalone webapp using 3.1.5 Resin. Find the attached web.xml and the simple jsp file that prints the following output. This was tested with a freshly installed resin 3.1.5 and only the two files.

http://localhost:8080/s/index.jsp?foo=bar [^]

Request Param [ foo ] value [ 0 ] = bar
Request Param [ foo ] value [ 1 ] = bar


http://localhost:8080/index.jsp?foo=bar [^]

Request Param [ foo ] value [ 0 ] = bar
 
(0002865)
ferg
03-20-08 14:58

server/1kn2
 

- Issue History
Date Modified Username Field Change
02-28-08 10:58 zdavis New Issue
02-01-08 10:11 sam Priority normal => urgent
03-05-08 09:36 ferg Note Added: 0002817
03-06-08 09:59 zdavis File Added: index.jsp
03-06-08 09:59 zdavis File Added: web.xml
03-06-08 10:02 zdavis Note Added: 0002833
03-20-08 14:58 ferg Note Added: 0002865
03-20-08 14:58 ferg Assigned To  => ferg
03-20-08 14:58 ferg Status new => closed
03-20-08 14:58 ferg Resolution open => fixed
03-20-08 14:58 ferg Fixed in Version  => 3.1.6
03-20-08 16:00 mhakim Issue Monitored: mhakim
03-20-08 16:00 mhakim Issue End Monitor: mhakim


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
39 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker