Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002406 [Quercus] major always 02-06-08 12:18 11-09-08 13:39
Reporter ckchris View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.5
Summary 0002406: phpbb3 throwing exception when connecting to oracle db (oci_new_connect)
Description Trying to install and setup phpbb3. Couldn't detect oracle on 3.1.4, so I upgraded to 3.1.5 to test it. Now, phpbb3 detect Oracle. Tried to connect to Oracle 11g and I get the following exception:

com.caucho.quercus.QuercusException: com.caucho.quercus.UnimplementedException:
`oci_new_connect with charset' has not been implemented. A more recent
version of Quercus may be available at http://www.caucho.com/download [^] Requests
for unimplemented features can be entered in the bugtrack http://bugs.caucho.com [^]
   ocinlogon() (at /var/vhosts/www.foo.com/phpbb3/includes/db/oracle.php:51)
   connect_check_db() (at /var/vhosts/www.foo.com/phpbb3/install/install_install.php:554)
   ObjectExtValue@1548732[install_install].$this->obtain_database_settings() (at /var/vhosts/www.foo.com/phpbb3/install/install_install.php:79)

    at com.caucho.quercus.QuercusException.create(QuercusException.java:72)
    at com.caucho.quercus.expr.FunctionExpr.evalImpl(FunctionExpr.java:184)
    at com.caucho.quercus.expr.FunctionExpr.evalCopy(FunctionExpr.java:150)
    at com.caucho.quercus.expr.SuppressErrorExpr.evalCopy(SuppressErrorExpr.java:145)
    at com.caucho.quercus.expr.ConditionalExpr.evalCopy(ConditionalExpr.java:101)
    at com.caucho.quercus.expr.AssignExpr.eval(AssignExpr.java:86)
    at com.caucho.quercus.program.ExprStatement.execute(ExprStatement.java:64)
    at com.caucho.quercus.program.BlockStatement.execute(BlockStatement.java:99)
    at com.caucho.quercus.program.Function.callImpl(Function.java:354)
    at com.caucho.quercus.program.Function.call(Function.java:294)
    at com.caucho.quercus.program.AbstractFunction.callMethod(AbstractFunction.java:309)
    at com.caucho.quercus.env.ObjectExtValue.callMethod(ObjectExtValue.java:602)
    at com.caucho.quercus.env.Var.callMethod(Var.java:1281)
    at _quercus._includes._functions_0install__php$fun_connect_check_db.callImpl(var/vhosts/www.foo.com/phpbb3/includes/functions_install.php:319)
    at com.caucho.quercus.program.CompiledFunction_N.call(CompiledFunction_N.java:95)
    at com.caucho.quercus.program.AbstractFunction.callCopy(AbstractFunction.java:271)
    at com.caucho.quercus.expr.FunctionExpr.evalImpl(FunctionExpr.java:180)
    at com.caucho.quercus.expr.FunctionExpr.evalCopy(FunctionExpr.java:150)
    at com.caucho.quercus.expr.AssignExpr.eval(AssignExpr.java:86)
    at com.caucho.quercus.program.ExprStatement.execute(ExprStatement.java:64)
    at com.caucho.quercus.program.IfStatement.execute(IfStatement.java:78)
    at com.caucho.quercus.program.BlockStatement.execute(BlockStatement.java:99)
    at com.caucho.quercus.program.IfStatement.execute(IfStatement.java:75)
    at com.caucho.quercus.program.BlockStatement.execute(BlockStatement.java:99)
    at com.caucho.quercus.program.Function.callImpl(Function.java:354)
    at com.caucho.quercus.program.Function.call(Function.java:294)
    at com.caucho.quercus.program.AbstractFunction.callMethod(AbstractFunction.java:309)
    at com.caucho.quercus.env.ObjectExtValue.callMethod(ObjectExtValue.java:602)
    at com.caucho.quercus.expr.MethodCallExpr.eval(MethodCallExpr.java:104)
    at com.caucho.quercus.program.ExprStatement.execute(ExprStatement.java:64)
    at com.caucho.quercus.program.BlockStatement.execute(BlockStatement.java:99)
    at com.caucho.quercus.program.SwitchStatement.execute(SwitchStatement.java:87)
    at com.caucho.quercus.program.BlockStatement.execute(BlockStatement.java:99)
    at com.caucho.quercus.program.Function.callImpl(Function.java:354)
    at com.caucho.quercus.program.Function.call(Function.java:294)
    at com.caucho.quercus.program.AbstractFunction.callMethod(AbstractFunction.java:309)
    at com.caucho.quercus.program.AbstractFunction.callMethod(AbstractFunction.java:511)
    at com.caucho.quercus.env.ObjectExtValue.callMethod(ObjectExtValue.java:668)
    at _quercus._install._index__php$quercus_module$fun_load.callMethod(var/vhosts/www.foo.com/phpbb3/install/index.php:402)
    at com.caucho.quercus.program.CompiledMethod_2.callMethod(CompiledMethod_2.java:105)
    at com.caucho.quercus.env.ObjectExtValue.callMethod(ObjectExtValue.java:623)
    at com.caucho.quercus.env.Var.callMethod(Var.java:1290)
    at _quercus._install._index__php.execute(var/vhosts/www.foo.com/phpbb3/install/index.php:274)
    at com.caucho.quercus.page.QuercusPage.executeTop(QuercusPage.java:119)
    at com.caucho.quercus.servlet.ResinQuercusServlet.service(ResinQuercusServlet.java:146)
    at com.caucho.quercus.servlet.QuercusServlet.service(QuercusServlet.java:353)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:91)
    at com.caucho.server.dispatch.ServletFilterChain.doFilter(ServletFilterChain.java:103)
    at com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:181)
    at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:266)
    at com.caucho.server.hmux.HmuxRequest.handleRequest(HmuxRequest.java:435)
    at com.caucho.server.port.TcpConnection.run(TcpConnection.java:603)
    at com.caucho.util.ThreadPool$Item.runTasks(ThreadPool.java:721)
    at com.caucho.util.ThreadPool$Item.run(ThreadPool.java:643)
    at java.lang.Thread.run(Thread.java:595)
Caused by: com.caucho.quercus.UnimplementedException: `oci_new_connect
with charset' has not been implemented. A more recent version of Quercus
may be available at http://www.caucho.com/download [^] Requests for unimplemented
features can be entered in the bugtrack http://bugs.caucho.com [^]
    at com.caucho.quercus.lib.db.OracleModule.oci_new_connect(OracleModule.java:1393)
    at com.caucho.quercus.lib.db.OracleModule.ocinlogon(OracleModule.java:2064)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at com.caucho.quercus.module.StaticFunction.invoke(StaticFunction.java:129)
    at com.caucho.quercus.env.JavaInvoker.callMethod(JavaInvoker.java:604)
    at com.caucho.quercus.env.JavaInvoker.call(JavaInvoker.java:539)
    at com.caucho.quercus.env.AbstractJavaMethod.callCopy(AbstractJavaMethod.java:91)
    at com.caucho.quercus.expr.FunctionExpr.evalImpl(FunctionExpr.java:180)
    at com.caucho.quercus.expr.FunctionExpr.evalCopy(FunctionExpr.java:150)
    at com.caucho.quercus.expr.SuppressErrorExpr.evalCopy(SuppressErrorExpr.java:145)
    at com.caucho.quercus.expr.ConditionalExpr.evalCopy(ConditionalExpr.java:101)
    at com.caucho.quercus.expr.AssignExpr.eval(AssignExpr.java:86)
    at com.caucho.quercus.program.ExprStatement.execute(ExprStatement.java:64)
    at com.caucho.quercus.program.BlockStatement.execute(BlockStatement.java:99)
    at com.caucho.quercus.program.Function.callImpl(Function.java:354)
    at com.caucho.quercus.program.Function.call(Function.java:294)
    at com.caucho.quercus.program.AbstractFunction.callMethod(AbstractFunction.java:309)
    at com.caucho.quercus.env.ObjectExtValue.callMethod(ObjectExtValue.java:602)
    at com.caucho.quercus.env.Var.callMethod(Var.java:1281)
    at _quercus._includes._functions_0install__php$fun_connect_check_db.callImpl(var/vhosts/www.foo.com/phpbb3/includes/functions_install.php:319)
    at com.caucho.quercus.program.CompiledFunction_N.call(CompiledFunction_N.java:95)
    at com.caucho.quercus.program.AbstractFunction.callCopy(AbstractFunction.java:271)
    at com.caucho.quercus.expr.FunctionExpr.evalImpl(FunctionExpr.java:180)
    at com.caucho.quercus.expr.FunctionExpr.evalCopy(FunctionExpr.java:150)
    at com.caucho.quercus.expr.AssignExpr.eval(AssignExpr.java:86)
    at com.caucho.quercus.program.ExprStatement.execute(ExprStatement.java:64)
    at com.caucho.quercus.program.IfStatement.execute(IfStatement.java:78)
    at com.caucho.quercus.program.BlockStatement.execute(BlockStatement.java:99)
    at com.caucho.quercus.program.IfStatement.execute(IfStatement.java:75)
    at com.caucho.quercus.program.BlockStatement.execute(BlockStatement.java:99)
    at com.caucho.quercus.program.Function.callImpl(Function.java:354)
    at com.caucho.quercus.program.Function.call(Function.java:294)
    at com.caucho.quercus.program.AbstractFunction.callMethod(AbstractFunction.java:309)
    at com.caucho.quercus.env.ObjectExtValue.callMethod(ObjectExtValue.java:602)
    at com.caucho.quercus.expr.MethodCallExpr.eval(MethodCallExpr.java:104)
    at com.caucho.quercus.program.ExprStatement.execute(ExprStatement.java:64)
    at com.caucho.quercus.program.BlockStatement.execute(BlockStatement.java:99)
    at com.caucho.quercus.program.SwitchStatement.execute(SwitchStatement.java:87)
    at com.caucho.quercus.program.BlockStatement.execute(BlockStatement.java:99)
    at com.caucho.quercus.program.Function.callImpl(Function.java:354)
    at com.caucho.quercus.program.Function.call(Function.java:294)
    at com.caucho.quercus.program.AbstractFunction.callMethod(AbstractFunction.java:309)
    at com.caucho.quercus.program.AbstractFunction.callMethod(AbstractFunction.java:511)
    at com.caucho.quercus.env.ObjectExtValue.callMethod(ObjectExtValue.java:668)
    at _quercus._install._index__php$quercus_module$fun_load.callMethod(var/vhosts/www.foo.com/phpbb3/install/index.php:402)
    at com.caucho.quercus.program.CompiledMethod_2.callMethod(CompiledMethod_2.java:105)
    at com.caucho.quercus.env.ObjectExtValue.callMethod(ObjectExtValue.java:623)
    at com.caucho.quercus.env.Var.callMethod(Var.java:1290)
    at _quercus._install._index__php.execute(var/vhosts/www.foo.com/phpbb3/install/index.php:274)
    at com.caucho.quercus.page.QuercusPage.executeTop(QuercusPage.java:119)
    at com.caucho.quercus.servlet.ResinQuercusServlet.service(ResinQuercusServlet.java:146)
    at com.caucho.quercus.servlet.QuercusServlet.service(QuercusServlet.java:353)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:91)
    at com.caucho.server.dispatch.ServletFilterChain.doFilter(ServletFilterChain.java:103)
    at com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:181)
    at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:266)
    at com.caucho.server.hmux.HmuxRequest.handleRequest(HmuxRequest.java:435)
    at com.caucho.server.port.TcpConnection.run(TcpConnection.java:603)
    at com.caucho.util.ThreadPool$Item.runTasks(ThreadPool.java:721)
    at com.caucho.util.ThreadPool$Item.run(ThreadPool.java:643)
    at java.lang.Thread.run(Thread.java:595)
Caused by: com.caucho.quercus.QuercusExecutionException: com.caucho.quercus.UnimplementedException
`oci_new_connect with charset' has not been implemented. A more recent
version of Quercus may be available at http://www.caucho.com/download [^] Requests
for unimplemented features can be entered in the bugtrack http://bugs.caucho.com [^]


oci_new_connect is the culprit with the new character set maybe?

Additional Information
Attached Files

- Relationships

- Notes
(0003114)
ferg
05-01-08 14:59

php/440c
 

- Issue History
Date Modified Username Field Change
02-06-08 12:18 ckchris New Issue
02-06-08 12:18 ckchris Issue Monitored: ckchris
05-01-08 14:59 ferg Note Added: 0003114
05-01-08 14:59 ferg Assigned To  => ferg
05-01-08 14:59 ferg Status new => closed
05-01-08 14:59 ferg Resolution open => fixed
05-01-08 14:59 ferg Fixed in Version  => 3.2.0
08-01-08 16:29 ckchris Issue End Monitor: ckchris
11-09-08 07:07 ferg Description Updated
11-09-08 13:39 ferg Description Updated


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
33 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker