Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002386 [Resin] major always 01-03-08 01:15 02-07-08 14:35
Reporter killnine View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.3
Summary 0002386: Initialization order of filters and servlets does not follow the Servlet spec 2.5
Description Servlet specification 2.5, article SRV.9.12 clearly states, that instantiation and initialization of filters should be done before servlets, regardless of their load-on-startup configuration.

This doesn't seem to be the case. My application has a closely related filter and servlet pair, and servlet depends on initializations made by the filter. My servlet throws an exception at deployment time because the filter initialization has not been done yet.

A quick glance at com.caucho.server.webapp.WebApp supported the impression that the init sequence is wrong: lines 1800 and 1801 call _servletManager.init() and _filterManager.init(), in this order.
Additional Information
Attached Files

- Relationships

- Notes
(0002734)
ferg
02-07-08 14:35

server/1719
 

- Issue History
Date Modified Username Field Change
01-03-08 01:15 killnine New Issue
01-03-08 01:15 killnine Issue Monitored: killnine
02-07-08 14:35 ferg Note Added: 0002734
02-07-08 14:35 ferg Assigned To  => ferg
02-07-08 14:35 ferg Status new => closed
02-07-08 14:35 ferg Resolution open => fixed
02-07-08 14:35 ferg Fixed in Version  => 3.1.5


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
30 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker