Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002349 [Resin] minor always 01-20-08 11:20 01-01-08 17:24
Reporter netsql2 View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0002349: Hessian Flex Comet Feature Request (rewrite in acction script w/o Flex MXML classes imported)
Description Hessian Flex is great and we use it at PointCast.com, w/ & w/o Comet.

The current implementation is using/importing Flex MXML classes as opposed to using just .as3 project (Flex w/o MXML).
This makes the code MUCH larger by a few 100K as it needs to download dependent MXML classes and it makes it a bit harder to edit MXML vs .as3 in FlexBuilder (ex: I can see methods in outline in Eclipse or FlexBuidler in MXML, but I can in .as).
Other Flex projects (ex: PaperVision) don't us the MXML classes making them much easier to edit and much smaller. Three are other socket libraries in Flex that are using only .as3 and not using any MXML classes so I assume this is possible.
(Of course .as3 library can be used in MXML library, but right now you if you want to do .as3 code, you can't use Hessian).

Our PointCast project would lose 2/3 of size if Hessian Flex impl was in .as3, the only reason we use MXML is due to Hessian Flex impl.
This feature request is low priority.
Additional Information
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
01-20-08 11:20 netsql2 New Issue
01-01-08 17:24 emil Status new => closed
01-01-08 17:24 emil Resolution open => fixed
01-01-08 17:24 emil Fixed in Version  => 3.1.5


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
27 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker