Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002331 [Resin] minor always 01-14-08 10:42 02-13-08 09:40
Reporter nam View Status public  
Assigned To ferg
Priority urgent Resolution fixed  
Status closed   Product Version 3.1.4
Summary 0002331: 64-bit and Windows Server 2003 - JNI dlls not loading
Description (rep by K. Puaa)

We are running a
       - Intel Xeon (EM64T)
       - Windows Server 2003 R2 (64 Bit)
system. We are unable to get any combination of the following Resin
versions and JDK versions to enable the JNI Socket Library.
It is important that we get this running. We need to support
64-bit and SSL. Thus we need the ability to run the JNI resinssl dll.
- resin-pro-3.0.25
- resin-pro-3.1.1
- (for version 3.1.2 and above the -d64 flag is automatically set
    even though this is a solaris 64-bit option only. Therefore we
    have not been able to get these versions to start a jvm let
    alone load the JNDI socket libraries.)
JAVA -- (All are 64-bit)
- (Sun) jdk1.50_14
- (BEA) jrockit-R27.4.0-jdk1.5.0_11
- (BEA) jrockit-R27.4.0-jdk1.6.0_02
When I visit [^] bug 0001250 seems to
directly apply to my solution. The fix claims that version 3.1.1
should solve my problem. Please advise!! We need a solution quick
I also have license key #xxx and include the win32 directory in my path.
Here is summary of the problem
    * Get resin to run with OpenSSL (i.e. load JNI dll resinssl.dll) on the following environment
               - Intel Xeon (EM64T)
               - Windows Server 2003 R2 (64 Bit)
    * Resin runs but reports "Socket JNI library is not available" (When loading resin without SSL)
    * Socket JNI unavailability leads to errors running OpenSSL since resinssl.dll is required.
    * Worked on including the win32 directory in the path
    * Tried the multiple combinations of the above listed JDK versions and Resin versions.
Additional Information
Attached Files

- Relationships

- Notes
01-22-08 13:47

(rep by R Lockstone)

We need to run Rsin, with OpenSSL, on Windows 2003 Server

Also, it would be helpful for us if each release indicated the website of the OpenSSL dll's that were used to build on Windows.

For Resin 3.0, we get the following error (even though we have Intel CPU's)

java.lang.UnsatisfiedLinkError: D:\resin\win32\resinssl.dll: Can't
load IA 32-bit .dll on a AMD 64-bit platform

This is new hardware and we weren't aware that Resin's SSL DLL would
not be compatible with the underlying architecture. We don't have
this problem with our older hardware, which is also Xeon-based.

Unfortunately, swapping hardware at this point would be a major

Do you know of a workaround? Or can you build us a version of
resinssl.dll (and any other dll's that might be needed) that will
work on this hardware?

- Issue History
Date Modified Username Field Change
01-14-08 10:42 nam New Issue
01-22-08 13:47 sam Note Added: 0002663
01-22-08 13:47 sam Priority normal => urgent
02-13-08 09:40 ferg Assigned To  => ferg
02-13-08 09:40 ferg Status new => closed
02-13-08 09:40 ferg Resolution open => fixed
02-13-08 09:40 ferg Fixed in Version  => 3.1.5

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
28 unique queries executed.
Powered by Mantis Bugtracker