Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002295 [Resin] major always 01-07-08 23:41 01-08-08 12:22
Reporter norlab View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.5
Summary 0002295: Compiling resin on solaris 10
Description Can not get resin to compile on Solaris 10 Sparc. This is compile of most recent snapshot from 12/31/07.

./configure --with-apxs=/usr/local/apache/bin/apxs --enable-64bit --enable-jni --disable-ssl --with-gnu-ld --with-tag=CXX. Also tried without the last two flags with the same error.
Additional Information Configure completes successfully & make produces following error.

(cd modules/c/src; make)
for dir in common apache2 resin resinssl resin_os resin_os; do (cd $dir; make); done
/usr/ccs/bin/ld -r -o common.o stream.o config.o memory.o
/usr/local/src/resin-pro-3.1.s071231/libtool --silent --mode=compile gcc -o stream.lo -c -g -O2 -DPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI stream.c
/usr/local/src/resin-pro-3.1.s071231/libtool --silent --mode=compile gcc -o config.lo -c -g -O2 -DPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI config.c
/usr/local/src/resin-pro-3.1.s071231/libtool --silent --mode=compile gcc -o memory.lo -c -g -O2 -DPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI memory.c
EGREP="egrep" /usr/local/src/resin-pro-3.1.s071231/libtool --silent --mode=compile gcc -o mod_caucho.lo -c -I/usr/local/apache/include -I/usr/local/apache/include -DRESIN_HOME=\"/usr/local/src/resin-pro-3.1.s071231\" -I../common -g -O2 -DPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI -DSOLARIS2=10 -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -g -O2 mod_caucho.c
EGREP="egrep" /usr/local/src/resin-pro-3.1.s071231/libtool --silent --mode=link /usr/ccs/bin/ld -module -o -avoid-version -rpath /usr/local/apache/modules mod_caucho.lo ../common/stream.lo ../common/config.lo ../common/memory.lo
libtool: link: unable to infer tagged configuration
libtool: link: specify a tag with `--tag'
*** Error code 1
make: Fatal error: Command failed for target `'
Current working directory /usr/local/src/resin-pro-3.1.s071231/modules/c/src/apache2
gcc -g -O2 -DPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI -DRESIN_HOME=\"/usr/local/src/resin-pro-3.1.s071231\" -I/usr/java/include -I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -m64 -fPIC -c std.c
gcc -g -O2 -DPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI -DRESIN_HOME=\"/usr/local/src/resin-pro-3.1.s071231\" -I/usr/java/include -I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -m64 -fPIC -c memory.c
gcc -g -O2 -DPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI -DRESIN_HOME=\"/usr/local/src/resin-pro-3.1.s071231\" -I/usr/java/include -I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -m64 -fPIC -c jni_vfs.c
gcc -g -O2 -DPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI -DRESIN_HOME=\"/usr/local/src/resin-pro-3.1.s071231\" -I/usr/java/include -I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -m64 -fPIC -c java.c
gcc -g -O2 -DPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI -DRESIN_HOME=\"/usr/local/src/resin-pro-3.1.s071231\" -I/usr/java/include -I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -m64 -fPIC -c boot.c
gcc -g -O2 -DPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI -DRESIN_HOME=\"/usr/local/src/resin-pro-3.1.s071231\" -I/usr/java/include -I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -m64 -fPIC -c profile.c
gcc -g -O2 -DPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI -DRESIN_HOME=\"/usr/local/src/resin-pro-3.1.s071231\" -I/usr/java/include -I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -m64 -fPIC -c heap.c
gcc -g -O2 -DPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI -DRESIN_HOME=\"/usr/local/src/resin-pro-3.1.s071231\" -I/usr/java/include -I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -m64 -fPIC -c lru.c
lru.c: In function `profile_hash_code':
lru.c:85: warning: cast from pointer to integer of different size
gcc -g -O2 -DPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI -DRESIN_HOME=\"/usr/local/src/resin-pro-3.1.s071231\" -I/usr/java/include -I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -m64 -fPIC -c symbol.c
/usr/ccs/bin/ld -G -fPIC -o std.o memory.o jni_vfs.o java.o boot.o profile.o heap.o lru.o symbol.o crc64.o -lnsl -lsocket -lthread
gcc -g -O2 -DPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI -DRESIN_HOME=\"/usr/local/src/resin-pro-3.1.s071231\" -I/usr/java/include -I/usr/java/include/solaris -I../common -I../resin -DCPU=\"sparcv9\" -DOS= -m64 -fPIC -c ssl_stub.c
/usr/ccs/bin/ld -G -fPIC -o ssl_stub.o ../resin/memory.o ../resin/std.o ../resin/java.o -lnsl -lsocket -lthread
gcc -g -O2 -DPOLL -D_POSIX_PTHREAD_SEMANTICS -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI -m64 -DRESIN_HOME=\"/usr/local/src/resin-pro-3.1.s071231\" -I/usr/java/include -I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -c jni_os.c
/usr/ccs/bin/ld -G -fPIC -o jni_os.o jni_jvmti.o jni_jvmdi.o -lnsl -lsocket -lthread
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
01-07-08 23:41 norlab New Issue
01-08-08 12:22 ferg Assigned To  => ferg
01-08-08 12:22 ferg Status new => closed
01-08-08 12:22 ferg Resolution open => fixed
01-08-08 12:22 ferg Fixed in Version  => 3.1.5

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
27 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker