Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002265 [Resin] block always 12-18-07 22:50 12-03-07 17:06
Reporter Kenneth123 View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.4
Summary 0002265: A Signature requires the method signature.
Description I get the following errors for a very simple web app developed using NetBeans 6 IDE when using Resin 3.1.4 but it works perfectly on Apache Tomcat 6.0.14. Thank you in advance for any help. My server uses Resin so I obviously need to get this error fixed.

Description: An unhandled exception occurred during the execution of the web application. Please review the following stack trace for more information regarding the error.

Exception Details: com.caucho.config.ConfigException
  A Signature requires the method signature.

Possible Source of Error:
   Class Name: com.caucho.config.types.Signature
   File Name: Signature.java
   Method Name: init
   Line Number: 146

Source not available. Information regarding the location of the exception can be identified using the exception stack trace below.

Stack Trace:

com.caucho.config.types.Signature.init(Signature.java:146)
sun.reflect.GeneratedMethodAccessor50.invoke( Unknown Source )
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
java.lang.reflect.Method.invoke(Method.java:597)
com.caucho.config.j2ee.PostConstructProgram.configureImpl(PostConstructProgram.java:62)
com.caucho.config.BeanTypeStrategy.init(BeanTypeStrategy.java:389)
com.caucho.config.NodeBuilder.configureChildNode(NodeBuilder.java:418)
com.caucho.config.NodeBuilder.configureNode(NodeBuilder.java:301)
com.caucho.config.NodeBuilder.configureChildNode(NodeBuilder.java:414)
com.caucho.config.NodeBuilder.configureNode(NodeBuilder.java:301)
com.caucho.config.NodeBuilder.configureChildNode(NodeBuilder.java:414)
com.caucho.config.NodeBuilder.configureNode(NodeBuilder.java:301)
com.caucho.config.NodeBuilder.configureChildNode(NodeBuilder.java:414)
com.caucho.config.NodeBuilder.configureNode(NodeBuilder.java:301)
com.caucho.config.NodeBuilder.configureBean(NodeBuilder.java:205)
com.caucho.config.NodeBuilder.configure(NodeBuilder.java:162)
com.caucho.config.Config.configure(Config.java:268)
com.caucho.config.Config.configure(Config.java:238)
com.caucho.jsp.TldManager.parseTld(TldManager.java:622)
com.caucho.jsp.TldManager.parseTld(TldManager.java:583)
com.caucho.jsp.TldManager.parseTld(TldManager.java:464)
com.caucho.jsp.TaglibManager.readTaglib(TaglibManager.java:251)
com.caucho.jsp.TaglibManager.getTaglib(TaglibManager.java:172)
com.caucho.jsp.ParseTagManager.addTaglib(ParseTagManager.java:226)
com.caucho.jsp.java.JavaJspGenerator.addTaglib(JavaJspGenerator.java:393)
com.caucho.jsp.java.JavaJspGenerator.addOptionalTaglib(JavaJspGenerator.java:378)
com.caucho.jsp.java.JavaJspBuilder.startPrefixMapping(JavaJspBuilder.java:367)
com.caucho.jsp.JspParser.parseAttributes(JspParser.java:1445)
com.caucho.jsp.JspParser.parseOpenTag(JspParser.java:1322)
com.caucho.jsp.JspParser.parseNode(JspParser.java:544)
com.caucho.jsp.JspParser.parseJsp(JspParser.java:374)
com.caucho.jsp.JspParser.parse(JspParser.java:263)
com.caucho.jsp.JspCompilerInstance.generate(JspCompilerInstance.java:490)
com.caucho.jsp.JspCompilerInstance.compile(JspCompilerInstance.java:386)
com.caucho.jsp.JspManager.compile(JspManager.java:241)
com.caucho.jsp.JspManager.createPage(JspManager.java:170)
com.caucho.jsp.JspManager.createPage(JspManager.java:149)
com.caucho.jsp.PageManager.getPage(PageManager.java:247)
com.caucho.jsp.PageManager.getPage(PageManager.java:177)
com.caucho.jsp.PageManager.getPage(PageManager.java:160)
com.caucho.jsp.QServlet.getSubPage(QServlet.java:295)
com.caucho.jsp.QServlet.getPage(QServlet.java:210)
com.caucho.server.dispatch.PageFilterChain.compilePage(PageFilterChain.java:235)
com.caucho.server.dispatch.PageFilterChain.doFilter(PageFilterChain.java:145)
com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:181)
com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:266)
com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:268)
com.caucho.server.port.TcpConnection.run(TcpConnection.java:602)
com.caucho.util.ThreadPool$Item.runTasks(ThreadPool.java:690)
com.caucho.util.ThreadPool$Item.run(ThreadPool.java:612)
java.lang.Thread.run(Thread.java:619)

Exception Details: com.caucho.config.LineConfigException
  jar:file:/D:/Program%20Installers/Programming/Resin%203.1.4/resin-3.1.4/webapps/ResounzWebApp3/WEB-INF/lib/webui-jsf.jar!/META-INF/webui-jsf.tld:39758: A Signature requires the method signature.

Possible Source of Error:
   Class Name: com.caucho.config.NodeBuilder
   File Name: NodeBuilder.java
   Method Name: error
   Line Number: 1019

Source not available. Information regarding the location of the exception can be identified using the exception stack trace below.

Stack Trace:

com.caucho.config.NodeBuilder.error(NodeBuilder.java:1019)
com.caucho.config.NodeBuilder.configureChildNode(NodeBuilder.java:430)
com.caucho.config.NodeBuilder.configureNode(NodeBuilder.java:301)
com.caucho.config.NodeBuilder.configureChildNode(NodeBuilder.java:414)
com.caucho.config.NodeBuilder.configureNode(NodeBuilder.java:301)
com.caucho.config.NodeBuilder.configureChildNode(NodeBuilder.java:414)
com.caucho.config.NodeBuilder.configureNode(NodeBuilder.java:301)
com.caucho.config.NodeBuilder.configureChildNode(NodeBuilder.java:414)
com.caucho.config.NodeBuilder.configureNode(NodeBuilder.java:301)
com.caucho.config.NodeBuilder.configureBean(NodeBuilder.java:205)
com.caucho.config.NodeBuilder.configure(NodeBuilder.java:162)
com.caucho.config.Config.configure(Config.java:268)
com.caucho.config.Config.configure(Config.java:238)
com.caucho.jsp.TldManager.parseTld(TldManager.java:622)
com.caucho.jsp.TldManager.parseTld(TldManager.java:583)
com.caucho.jsp.TldManager.parseTld(TldManager.java:464)
com.caucho.jsp.TaglibManager.readTaglib(TaglibManager.java:251)
com.caucho.jsp.TaglibManager.getTaglib(TaglibManager.java:172)
com.caucho.jsp.ParseTagManager.addTaglib(ParseTagManager.java:226)
com.caucho.jsp.java.JavaJspGenerator.addTaglib(JavaJspGenerator.java:393)
com.caucho.jsp.java.JavaJspGenerator.addOptionalTaglib(JavaJspGenerator.java:378)
com.caucho.jsp.java.JavaJspBuilder.startPrefixMapping(JavaJspBuilder.java:367)
com.caucho.jsp.JspParser.parseAttributes(JspParser.java:1445)
com.caucho.jsp.JspParser.parseOpenTag(JspParser.java:1322)
com.caucho.jsp.JspParser.parseNode(JspParser.java:544)
com.caucho.jsp.JspParser.parseJsp(JspParser.java:374)
com.caucho.jsp.JspParser.parse(JspParser.java:263)
com.caucho.jsp.JspCompilerInstance.generate(JspCompilerInstance.java:490)
com.caucho.jsp.JspCompilerInstance.compile(JspCompilerInstance.java:386)
com.caucho.jsp.JspManager.compile(JspManager.java:241)
com.caucho.jsp.JspManager.createPage(JspManager.java:170)
com.caucho.jsp.JspManager.createPage(JspManager.java:149)
com.caucho.jsp.PageManager.getPage(PageManager.java:247)
com.caucho.jsp.PageManager.getPage(PageManager.java:177)
com.caucho.jsp.PageManager.getPage(PageManager.java:160)
com.caucho.jsp.QServlet.getSubPage(QServlet.java:295)
com.caucho.jsp.QServlet.getPage(QServlet.java:210)
com.caucho.server.dispatch.PageFilterChain.compilePage(PageFilterChain.java:235)
com.caucho.server.dispatch.PageFilterChain.doFilter(PageFilterChain.java:145)
com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:181)
com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:266)
com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:268)
com.caucho.server.port.TcpConnection.run(TcpConnection.java:602)
com.caucho.util.ThreadPool$Item.runTasks(ThreadPool.java:690)
com.caucho.util.ThreadPool$Item.run(ThreadPool.java:612)
java.lang.Thread.run(Thread.java:619)

Exception Details: com.caucho.jsp.JspLineParseException
  jar:file:/D:/Program%20Installers/Programming/Resin%203.1.4/resin-3.1.4/webapps/ResounzWebApp3/WEB-INF/lib/webui-jsf.jar!/META-INF/webui-jsf.tld:39758: A Signature requires the method signature.

Possible Source of Error:
   Class Name: com.caucho.jsp.JspParseException
   File Name: JspParseException.java
   Method Name: create
   Line Number: 67

Source not available. Information regarding the location of the exception can be identified using the exception stack trace below.

Stack Trace:

com.caucho.jsp.JspParseException.create(JspParseException.java:67)
com.caucho.jsp.TaglibManager.readTaglib(TaglibManager.java:258)
com.caucho.jsp.TaglibManager.getTaglib(TaglibManager.java:172)
com.caucho.jsp.ParseTagManager.addTaglib(ParseTagManager.java:226)
com.caucho.jsp.ParseTagManager.addTaglib(ParseTagManager.java:189)
com.caucho.jsp.ParseTagManager.getTagImpl(ParseTagManager.java:108)
com.caucho.jsp.ParseTagManager.getTag(ParseTagManager.java:81)
com.caucho.jsp.java.JavaJspGenerator.getTag(JavaJspGenerator.java:2215)
com.caucho.jsp.java.JavaJspBuilder.startElement(JavaJspBuilder.java:248)
com.caucho.jsp.JspParser.parseOpenTag(JspParser.java:1329)
com.caucho.jsp.JspParser.parseNode(JspParser.java:544)
com.caucho.jsp.JspParser.parseJsp(JspParser.java:374)
com.caucho.jsp.JspParser.parse(JspParser.java:263)
com.caucho.jsp.JspCompilerInstance.generate(JspCompilerInstance.java:490)
com.caucho.jsp.JspCompilerInstance.compile(JspCompilerInstance.java:386)
com.caucho.jsp.JspManager.compile(JspManager.java:241)
com.caucho.jsp.JspManager.createPage(JspManager.java:170)
com.caucho.jsp.JspManager.createPage(JspManager.java:149)
com.caucho.jsp.PageManager.getPage(PageManager.java:247)
com.caucho.jsp.PageManager.getPage(PageManager.java:177)
com.caucho.jsp.PageManager.getPage(PageManager.java:160)
com.caucho.jsp.QServlet.getSubPage(QServlet.java:295)
com.caucho.jsp.QServlet.getPage(QServlet.java:210)
com.caucho.server.dispatch.PageFilterChain.compilePage(PageFilterChain.java:235)
com.caucho.server.dispatch.PageFilterChain.doFilter(PageFilterChain.java:145)
com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:181)
com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:266)
com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:268)
com.caucho.server.port.TcpConnection.run(TcpConnection.java:602)
com.caucho.util.ThreadPool$Item.runTasks(ThreadPool.java:690)
com.caucho.util.ThreadPool$Item.run(ThreadPool.java:612)
java.lang.Thread.run(Thread.java:619)

Exception Details: com.caucho.jsp.JspLineParseException
  jar:file:/D:/Program%20Installers/Programming/Resin%203.1.4/resin-3.1.4/webapps/ResounzWebApp3/WEB-INF/lib/webui-jsf.jar!/META-INF/webui-jsf.tld:39758: A Signature requires the method signature.

Possible Source of Error:
   Class Name: com.caucho.jsp.java.JavaJspBuilder
   File Name: JavaJspBuilder.java
   Method Name: error
   Line Number: 478

Source not available. Information regarding the location of the exception can be identified using the exception stack trace below.

Stack Trace:

com.caucho.jsp.java.JavaJspBuilder.error(JavaJspBuilder.java:478)
com.caucho.jsp.java.JavaJspBuilder.startElement(JavaJspBuilder.java:250)
com.caucho.jsp.JspParser.parseOpenTag(JspParser.java:1329)
com.caucho.jsp.JspParser.parseNode(JspParser.java:544)
com.caucho.jsp.JspParser.parseJsp(JspParser.java:374)
com.caucho.jsp.JspParser.parse(JspParser.java:263)
com.caucho.jsp.JspCompilerInstance.generate(JspCompilerInstance.java:490)
com.caucho.jsp.JspCompilerInstance.compile(JspCompilerInstance.java:386)
com.caucho.jsp.JspManager.compile(JspManager.java:241)
com.caucho.jsp.JspManager.createPage(JspManager.java:170)
com.caucho.jsp.JspManager.createPage(JspManager.java:149)
com.caucho.jsp.PageManager.getPage(PageManager.java:247)
com.caucho.jsp.PageManager.getPage(PageManager.java:177)
com.caucho.jsp.PageManager.getPage(PageManager.java:160)
com.caucho.jsp.QServlet.getSubPage(QServlet.java:295)
com.caucho.jsp.QServlet.getPage(QServlet.java:210)
com.caucho.server.dispatch.PageFilterChain.compilePage(PageFilterChain.java:235)
com.caucho.server.dispatch.PageFilterChain.doFilter(PageFilterChain.java:145)
com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:181)
com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:266)
com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:268)
com.caucho.server.port.TcpConnection.run(TcpConnection.java:602)
com.caucho.util.ThreadPool$Item.runTasks(ThreadPool.java:690)
com.caucho.util.ThreadPool$Item.run(ThreadPool.java:612)
java.lang.Thread.run(Thread.java:619)
 
Additional Information
Attached Files

- Relationships

- Notes
(0002592)
ferg
12-20-07 15:23

What does line 39758 of the webui-jsf.tld look like?

That message looks like it's a bug in the .tld file. Tomcat does very minimal validation of .tld files, so it's possible the .tld is broken, but Tomcat isn't catching it.
 
(0002595)
Kenneth123
12-21-07 16:09

What does line 39758 of the webui-jsf.tld look like? It is the "<method-signature/>" line in the following extract from the tld file.

        <attribute>
            <name>actionExpression</name>
            <required>false</required>
            <deferred-method>
                <method-signature/>
            </deferred-method>
            <description><![CDATA[ The action attribute is used to specify the action to take when this
 component is activated by the user. The value of the action attribute
 must be one of the following:
 

     
  • an outcome string, used to indicate which page to display next,
     as defined by a navigation rule in the application configuration
     resource file <code>(faces-config.xml)</code>.
     

  •  
  • a JavaServer Faces EL expression that resolves to a backing bean
     method. The method must take no parameters and return an outcome string.
     The class that defines the method must implement the
     <code>java.io.Serializable</code> interface or
     <code>javax.faces.component.StateHolder</code> interface.
     

 

In the Tree and TreeNode components, the action applies only when
 attributes are used to define the tree and tree nodes. When facets are
 used, the action attribute does not apply to the facets.


]]></description>
        </attribute>

I hope this is useful. There doesn't seem to be any error in this part of the tld.
 
(0002607)
ferg
12-03-07 17:06

jsp/18v2

Technically, the <method-signature> shouldn't be empty.
 

- Issue History
Date Modified Username Field Change
12-18-07 22:50 Kenneth123 New Issue
12-20-07 15:23 ferg Note Added: 0002592
12-21-07 16:09 Kenneth123 Note Added: 0002595
12-03-07 17:06 ferg Note Added: 0002607
12-03-07 17:06 ferg Assigned To  => ferg
12-03-07 17:06 ferg Status new => closed
12-03-07 17:06 ferg Resolution open => fixed
12-03-07 17:06 ferg Fixed in Version  => 3.1.5


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
33 total queries executed.
28 unique queries executed.
Powered by Mantis Bugtracker