Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002260 [Resin] minor always 12-16-07 16:10 12-03-07 10:58
Reporter ckchris View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.3
Summary 0002260: Web service libraries should be updated in RESIN_HOME/lib directory
Description I am not exactly sure what version of JavaWS API that Resin is using. All I can tell is that jaxrpc-15.jar seems to be current library version.

There appears to be a new updated version of JavaWS API (version 2.0) out. Other libraries such as XFire and I believe AXIS have now started this new version.

Unfortunately, when deploying XFire under Resin, problems occur where Java WS is not being invoked properly (errors are not being thrown either). But for some strange reason (which I have no time to delve into xfire to find out) POJO methods called by the WS is being passed with null values for arguments even if the arguments are being called with values from the WS client.

Current webapp deploys fine under Tomcat. So this led me to believe that it's either an XML parser issue or a classloader issue.

Inside <web-app>, I tried to set the JAXP system properties to use Xerces, which did not do much good and still has problems. I then enabled the servlet-hack setting and voila, the service is working. I then removed the system properties and the web services still work.

The conclusion is that there is some sort of library file that's not matching up. My best guess is that some of the RESIN_HOME/lib libraries are a little outdated. Here's what I have for the XFire plugin under Grails:

activation-1.1.jar
jaxws-api-2.0.jar
jdom-1.0.jar
jsr173_api-1.0.jar
serializer.jar
stax-api-1.0.1.jar
stax-utils-20040917.jar
wsdl4j-1.6.1.jar
wss4j-1.5.1.jar
wstx-asl-3.2.0.jar
xerces-2.8.1.jar
xfire-aegis-grails-0.6.1.jar
xfire-all-1.2.6.jar
xfire-jsr181-api-1.0-M1.jar

Unfortunately, I cannot remove jaxrpc-15.jar because it appears to be a required library used by Resin server (I believe it's being used by FileServlet for some reason).

Filing a request to update the web service libraries if possible. Is there possibly another solution?
Additional Information
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
12-16-07 16:10 ckchris New Issue
12-16-07 16:15 ckchris Issue Monitored: ckchris
12-03-07 10:58 ferg Assigned To  => ferg
12-03-07 10:58 ferg Status new => closed
12-03-07 10:58 ferg Resolution open => fixed
12-03-07 10:58 ferg Fixed in Version  => 3.1.5


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
28 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker