Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002235 [Resin] minor always 12-11-07 10:12 12-17-07 16:14
Reporter sam View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.4
Summary 0002235: Misleading error messages if libresin.so is not available:
Description Resin reports a misleading error message at "fine" level if libresin.so is not available. A regular http port tries to use the JNI library, but the error is reported as if it is an SSL error.

Also, an error occurs earlier "java.lang.UnsatisfiedLinkError: no resin in java.library.path" and it should not have the full stack trace at "fine" level, only at "finer" or "finest".

09:23:22.132] java.io.IOException: Can't open OpenSSL port
'0.0.0.0:8080' because a valid license was not found.
[09:23:22.132] at
com.caucho.vfs.JniServerSocketImpl.create(JniServerSocketImpl.java:94)
[09:23:22.132] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)
[09:23:22.132] at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[09:23:22.132] at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[09:23:22.132] at java.lang.reflect.Method.invoke(Method.java:585)
[09:23:22.132] at
com.caucho.vfs.QJniServerSocket.createJNI(QJniServerSocket.java:135)
[09:23:22.132] at
com.caucho.vfs.QJniServerSocket.create(QJniServerSocket.java:73)
[09:23:22.132] at
com.caucho.vfs.QJniServerSocket.create(QJniServerSocket.java:61)
[09:23:22.132] at com.caucho.server.port.Port.bind(Port.java:964)
[09:23:22.132] at
com.caucho.server.cluster.Server.bindPorts(Server.java:1225)
[09:23:22.132] at com.caucho.server.cluster.Server.start(Server.java:1175)
Additional Information
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
12-11-07 10:12 sam New Issue
12-17-07 16:14 ferg Assigned To  => ferg
12-17-07 16:14 ferg Status new => closed
12-17-07 16:14 ferg Resolution open => fixed
12-17-07 16:14 ferg Fixed in Version  => 3.1.5
12-03-07 09:15 zhoufengb Issue Monitored: zhoufengb


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker