Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002228 [Resin] minor always 12-07-07 22:31 12-03-07 15:49
Reporter drsskelkar View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.4
Summary 0002228: Persistent problem in directory browsing servlet since 3.1.3 and 3.1.4 Windows XP SP-2
Description I am facing once very silly problem that is breaking my head all the time.
In one of my web application I deliberately wanted directory browsing ( listing of files in folder ) available.
So I configured web.xml as follows to enable directory listing (as per the specs.)

<servlet servlet-name="directory"
         servlet-class="com.caucho.servlets.DirectoryServlet">
  <init enable="true"/>
</servlet>

 It worked fine upto resin version 3.1.2 ( and all versions prior to that )
Since Resin Version 3.1.3 and 3.1.4 directory servlet is not working at all.

I have reported bug and opened ticket at bugs.caucho.com.
But to my surprise Caucho Engineers could not confirm this bug.
I have read on some other forum that someone else is also facing the same issue.
My OS is Windows XP ( Service Pack 2 )
Java Platform JDK 6 Update 3



Additional Information
Attached Files

- Relationships

- Notes
(0002556)
stbu
12-08-07 03:48
edited on: 12-08-07 03:49

I've encountered the same problem and reported issue 2168 about four weeks ago.

 
(0002605)
ferg
12-03-07 15:49

server/002v
 

- Issue History
Date Modified Username Field Change
12-07-07 22:31 drsskelkar New Issue
12-08-07 03:48 stbu Note Added: 0002556
12-08-07 03:49 stbu Note Edited: 0002556
12-03-07 15:49 ferg Note Added: 0002605
12-03-07 15:49 ferg Assigned To  => ferg
12-03-07 15:49 ferg Status new => closed
12-03-07 15:49 ferg Resolution open => fixed
12-03-07 15:49 ferg Fixed in Version  => 3.1.5


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
33 total queries executed.
28 unique queries executed.
Powered by Mantis Bugtracker