Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002050 [Resin] minor always 10-09-07 08:52 01-08-08 12:20
Reporter ksvee View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.3
Summary 0002050: mod_caucho doesn't work for Apache2.2 on Solaris 10 (sparc)
Description This is a repeat of the bug in Resin >3.0.14 said to be fixed in 3.1.1. See Issue ID 1330.

Building mod_caucho on Solaris10 (sparc) with Suns CC (cc: Sun C 5.8 Patch 121015-02 2006/03/29) (not gcc) for Apache 2.2.6 yields a mod_caucho that just doesn't work. It hooks into Apache so that the config directives are listed on Apaches "/server-info"-page, but no requests are sent to the Resin backend.

Building mod_caucho from latest 3.0 (3.0.24 atm) yields the same result. However - using the same build environment - a build of mod_caucho from 3.0.14 works perfectly.

A version history of tested Resin-releases used to build mod_caucho:

  1. Resin pro 3.0.14 - latest known version that works
  2. Resin pro 3.0.17 through Resin pro 3.0.24 - does not work
  3. Resin pro 3.1.1 through 3.1.3 - does not work

I've posted this bug previously as bugid 0001330, but it doesn't seem to be fixed in 3.1 as it was closed with. Could'n find out how to reopen the bug (sorry), so I'll open this as a new one.
Additional Information Builds are done on an older SunFire V240 with Solaris 10 (SunOS 5.10, sparc) using CC from Sun Studio (cc: Sun C 5.8 Patch 121015-02 2006/03/29).

Builds are done in parallell on an old Ultra-5 with Solaris 8 with the same c-compiler. The results are the same on the two boxes. On this older box we've also tried using an older Sun C compiler (SUNWspro), also with the same results.

Build statements:

  CC='cc' CCC='CC' \
  ./configure --with-apxs=/www/httpd-2.2.6/bin/apxs \
    --disable-ssl \
  make install

Environment is sanitized between builds to do clean builds.
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
10-09-07 08:52 ksvee New Issue
01-08-08 12:20 ferg Assigned To  => ferg
01-08-08 12:20 ferg Status new => closed
01-08-08 12:20 ferg Resolution open => fixed
01-08-08 12:20 ferg Fixed in Version  => 3.1.5

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
27 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker