Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000020 [Resin] minor always 03-07-05 00:00 11-30-05 14:43
Reporter mkrebs View Status public  
Assigned To
Priority high Resolution unable to reproduce  
Status closed   Product Version
Summary 0000020: Sessions don't get destroyed in srun cluster
Description RSN-11
We are using Resin Professional 3.0.12 with an srun cluster setup. Things work normal for some time, then sessions don't get destroyed any more. Sessions accumulate until the server crashes due to overload. With full logging enabled one can see that the cleanup thread which in normal operation cleans the timeouted sessions every second just diappears at some point in time, hence no more sessions get destroyed. Nothing else in the logs.
Additional Information
Attached Files

- Relationships

- Notes
(0000020)
ferg
03-07-05 00:00

According to the configuration, there is no persistent store.

So the fact that the configuration is clustered is irrelevant.

Therefore, the maximum number of sessions is the 4096 in the configuration. If that value causes an overload, it would need to be reduced. (Which would indicate that too much information is being put in the session.)
 
(0000021)
mkrebs
03-07-05 00:00

We followed your suggestion to reduce session max (The three in resin.conf defined webapps with new session max values of 2048/200/20), but still the problem occurs.

Some more details:
* some of the nodes work for weeks before the problems occurs ("cleanup" Thread vanishes / does nothing any more)
* on some nodes the problem occurs after some hours
* this happens in random order on all nodes, not always on the same node
* all nodes do the same
 
(0000022)
ferg
03-07-05 00:00

Can't reproduce this issue.
 

- Issue History
Date Modified Username Field Change
03-07-05 00:00 mkrebs New Issue
11-30-05 00:00 administrator Fixed in Version  => 3.0.13
11-30-05 14:43 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
29 unique queries executed.
Powered by Mantis Bugtracker