Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000178 [Resin] minor always 05-16-05 00:00 11-01-05 14:44
Reporter sun2bin View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.0.13
Summary 0000178: Sometimes unable to start on JDK1.4
Description RSN-178
Resin-3.0.s050516 (built Mon, 16 May 2005 08:34:43 PDT)
Copyright(c) 1998-2004 Caucho Technology. All rights reserved.

com.caucho.config.ConfigException: Resin Professional has detected fewer licenses (0) than required.
License files belong in $RESIN_HOME/licenses.
See http://www.caucho.com/sales [^] for licensing information.
        at com.caucho.license.LicenseStore.validate(LicenseStore.java:173)
        at com.caucho.license.LicenseCheckImpl.validate(LicenseCheckImpl.java:85)
        at com.caucho.server.resin.Resin.init(Resin.java)
        at com.caucho.server.resin.Resin.main(Resin.java:594)
  No valid Resin(R) Professional license found.

Using Resin Open Source under the GNU Public License (GPL).

  See http://www.caucho.com [^] for information on Resin Professional.

Starting Resin on Tue, 17 May 2005 09:41:57 +0800 (CST)

[09:42:01.782] Server[] starting
[09:42:01.972] Socket JNI library requires a valid Resin Professional License.
[09:42:01.972] See http://www.caucho.com/sales [^] for information.
[09:42:01.982] http listening to *:80
[09:42:02.203] java.lang.NoSuchMethodError: org.w3c.dom.Node.getBaseURI()Ljava/lang/String;
[09:42:02.203] at com.caucho.config.BeanTypeStrategy.configureBean(BeanTypeStrategy.java:209)
[09:42:02.203] at com.caucho.config.NodeBuilder.configureImpl(NodeBuilder.java:225)
[09:42:02.203] at com.caucho.config.NodeBuilder.configureChildImpl(NodeBuilder.java:271)
[09:42:02.203] at com.caucho.config.EnvironmentAttributeStrategy.configure(EnvironmentAttributeStrategy.java:55)
[09:42:02.203] at com.caucho.config.NodeBuilder.configureAttributeImpl(NodeBuilder.java:346)
[09:42:02.203] at com.caucho.config.TypeStrategy.configureAttribute(TypeStrategy.java:112)
[09:42:02.203] at com.caucho.config.EnvironmentTypeStrategy.configureAttribute(EnvironmentTypeStrategy.java:89)
[09:42:02.203] at com.caucho.config.NodeBuilder.configureAttribute(NodeBuilder.java:198)
[09:42:02.203] at com.caucho.config.NodeBuilderChildProgram.configureImpl(NodeBuilderChildProgram.java:54)
[09:42:02.203] at com.caucho.config.BuilderProgramContainer.configureImpl(BuilderProgramContainer.java:62)
[09:42:02.203] at com.caucho.config.BuilderProgram.configure(BuilderProgram.java:60)
[09:42:02.203] at com.caucho.server.deploy.EnvironmentDeployController.configureInstance(EnvironmentDeployController.java:396)
[09:42:02.203] at com.caucho.server.host.HostController.configureInstance(HostController.java:369)
[09:42:02.203] at com.caucho.server.host.HostController.configureInstance(HostController.java:77)
[09:42:02.203] at com.caucho.server.deploy.DeployController.startImpl(DeployController.java:554)
[09:42:02.203] at com.caucho.server.deploy.StartAutoRedeployAutoStrategy.startOnInit(StartAutoRedeployAutoStrategy.java:72)
[09:42:02.203] at com.caucho.server.deploy.DeployController.startOnInit(DeployController.java:444)
[09:42:02.203] at com.caucho.server.deploy.DeployContainer.start(DeployContainer.java:157)
[09:42:02.203] at com.caucho.server.host.HostContainer.start(HostContainer.java:468)
[09:42:02.203] at com.caucho.server.resin.ServletServer.start(ServletServer.java:936)
[09:42:02.203] at com.caucho.server.deploy.DeployController.startImpl(DeployController.java:556)
[09:42:02.203] at com.caucho.server.deploy.AbstractDeployControllerStrategy.start(AbstractDeployControllerStrategy.java:56)
[09:42:02.203] at com.caucho.server.deploy.DeployController.start(DeployController.java:452)
[09:42:02.203] at com.caucho.server.resin.ResinServer.start(ResinServer.java:465)
[09:42:02.203] at com.caucho.server.resin.Resin.init(Resin.java)
[09:42:02.203] at com.caucho.server.resin.Resin.main(Resin.java:594)
closing server
[09:42:36.442] Server[] stopping
Additional Information
Attached Files

- Relationships

- Notes
(0000202)
sun2bin
05-16-05 00:00

I found if <resin:include> is used in resin.conf, this problem occurs.
 
(0000203)
ferg
05-16-05 00:00

This looks like a jar classpath problem, using an old version of the xml/dom jar. Check the classpath.
 
(0000204)
briandeng
05-16-05 00:00

It looks as though the call to setBaseURI() requires JDK 1.5. Is Resin 3 supposed
to be compatible with JDK 1.4?

Does the fact that this bug was fixed in 3.0.14 mean it was made to be JDK 1.4
compatible again in 3.0.14?
 

- Issue History
Date Modified Username Field Change
05-16-05 00:00 sun2bin New Issue
11-01-05 00:00 administrator Fixed in Version  => 3.0.14
11-01-05 14:44 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
32 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker