Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001713 [Quercus] crash always 04-27-07 01:52 04-01-07 03:16
Reporter salishev View Status public  
Assigned To nam
Priority normal Resolution fixed  
Status closed   Product Version 3.1.1
Summary 0001713: rawurlencode(NULL) throws unexpected NullPointerException
Description I've rechecked with latest available resin-3.1.s070425

rawurlencode(NULL) still throws unexpected NullPointerException.
The behavior differs from the php 5.1.6 behavior which just returns NULL.
The problems makes impossible using dokuwiki-2006-11-06 (dokuwiki.org) over Resin.

500 Servlet Exception
java.lang.NullPointerException
    at com.caucho.quercus.lib.UrlModule.rawurlencode(UrlModule.java:327)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:589)
    at com.caucho.quercus.module.StaticFunction.invoke(StaticFunction.java:105)
    at com.caucho.quercus.env.JavaInvoker.call(JavaInvoker.java:614)
    at com.caucho.quercus.env.JavaInvoker.call(JavaInvoker.java:487)
    at com.caucho.quercus.env.JavaInvoker.call(JavaInvoker.java:473)
    at com.caucho.quercus.expr.FunctionExpr.evalImpl(FunctionExpr.java:180)
    at com.caucho.quercus.expr.FunctionExpr.eval(FunctionExpr.java:125)
    at com.caucho.quercus.expr.EqExpr.evalBoolean(EqExpr.java:64)
    at com.caucho.quercus.program.IfStatement.execute(IfStatement.java:74)
    at com.caucho.quercus.program.QuercusProgram.execute(QuercusProgram.java:239)
    at com.caucho.quercus.page.InterpretedPage.execute(InterpretedPage.java:61)
    at com.caucho.quercus.page.QuercusPage.executeTop(QuercusPage.java:115)
    at com.caucho.quercus.servlet.ResinQuercusServlet.service(ResinQuercusServlet.java:125)
    at com.caucho.quercus.servlet.QuercusServlet.service(QuercusServlet.java:341)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:92)
    at com.caucho.server.dispatch.ServletFilterChain.doFilter(ServletFilterChain.java:103)
    at com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:175)
    at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:240)
    at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:263)
    at com.caucho.server.port.TcpConnection.run(TcpConnection.java:477)
    at com.caucho.util.ThreadPool$Item.runTasks(ThreadPool.java:600)
    at com.caucho.util.ThreadPool$Item.run(ThreadPool.java:522)
    at java.lang.Thread.run(Thread.java:620)

I've attached simple test case to show the problem

Additional Information It's very strange Caucho reports compatiblity with DokuWiki on the site while DokuWiki doesn't work due to multiple problems in Quercus.
Attached Files  C:\\resin-3.1.s070425\\webapps\\ROOT\\test_rawurlencode.php [^] (79 bytes) 04-27-07 01:52

- Relationships

- Notes
(0001869)
nam
04-27-07 11:26

issue was fixed yesterday

php/1i03
 
(0001878)
nam
04-01-07 03:16

Most of the new issues with Dokuwiki are regression issues. Dokuwiki (2006-11-06) was last verified against the official 3.1.0 release. The snapshots that you are using are previews of upcoming releases. They should not be used in production environments because they have not went through our full QA, but they are invaluable in helping us receive feedback from our users.
 

- Issue History
Date Modified Username Field Change
04-27-07 01:52 salishev New Issue
04-27-07 01:52 salishev File Added: C:\\resin-3.1.s070425\\webapps\\ROOT\\test_rawurlencode.php
04-27-07 11:24 nam Status new => assigned
04-27-07 11:24 nam Assigned To  => nam
04-27-07 11:26 nam Status assigned => closed
04-27-07 11:26 nam Note Added: 0001869
04-27-07 11:26 nam Resolution open => fixed
04-27-07 11:26 nam Fixed in Version  => 3.1.1
04-01-07 03:16 nam Note Added: 0001878
04-01-07 03:16 nam Status closed => assigned
04-01-07 03:16 nam Status assigned => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
32 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker