Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001667 [Quercus] minor always 04-03-07 11:16 04-01-07 14:11
Reporter nam View Status public  
Assigned To nam
Priority normal Resolution fixed  
Status closed   Product Version 3.1.0
Summary 0001667: including a quercus page in Tomcat/Glassfish leads to IllegalStateException
Description The following will throw an IllegalStateException:

<jsp:include page="test.php" />

This is caused by a call by Quercus to response.getOutputStream(). Tomcat/Glassfish will always throw an IllegalStateException for calls to getOutputStream from included pages.

Because Tomcat/Glassfish share a common code base with respect to this issue, they are naturally both affected.
Additional Information
Attached Files

- Relationships

- Notes
(0001880)
nam
04-01-07 14:11

Quercus will now attempt to get a Writer if it fails to get an OutputStream.
 

- Issue History
Date Modified Username Field Change
04-03-07 11:16 nam New Issue
04-01-07 14:11 nam Status new => assigned
04-01-07 14:11 nam Assigned To  => nam
04-01-07 14:11 nam Status assigned => closed
04-01-07 14:11 nam Note Added: 0001880
04-01-07 14:11 nam Resolution open => fixed
04-01-07 14:11 nam Fixed in Version  => 3.1.1


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
28 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker