Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001661 [Resin] major always 03-01-07 06:16 06-06-07 16:17
Reporter resinossi View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.0.18
Summary 0001661: Problems with % character in URI
Description I'm experiencing the following problem with Apache, mod_caucho and Resin pro (3.0.18) combination:

If uri contains "%" character, mod_caucho doesn't seem to work correctly, eg.

"http://www.server.tld/home/user%name" [^] is encoded as

"http://www.server.tld/home/user%25name" [^] which won't work.

In Apache's access.log request looks like this:
10.1.3.165 - - [29/Mar/2007:16:04:54 +0200] "GET /home/ossi%25se HTTP/1.0" 200 27278 "-" "Wget/1.8.2"
And in Resin's access.log it looks like this:
10.1.3.165 - - [29/Mar/2007:16:04:53 +0200] "GET /home/ossi%se HTTP/1.0" 200 27278 "-" "Wget/1.8.2"


But "http://www.server.tld/home/user%2525name" [^] works.
In this case, Apache log:
10.1.3.165 - - [29/Mar/2007:16:11:25 +0200] "GET /home/ossi%2525se HTTP/1.0" 200 23141 "-" "Wget/1.8.2"
And resin's log:
10.1.3.165 - - [29/Mar/2007:16:11:25 +0200] "GET /home/ossi%25se HTTP/1.0" 200 23141 "-" "Wget/1.8.2"


If I replace "ResinConfigServer" with ProxyPass directives (configuring Apache connect to
Resin's HTTP port), the uri
"http://www.server.tld/home/user%25name" [^] works fine. Same thing, if connecting directly to Resin's http port.

Problem seems to be just with "%" character (which is a bit special), since
eg. "=" (%0d) works fine.

I have also tested with Resin pro 3.0.23's mod_caucho with same result.
Additional Information
Attached Files

- Relationships

- Notes
(0001932)
klemen
05-16-07 09:50

The very same problem is bugging me too. I haven't found any good solution yet.
 

- Issue History
Date Modified Username Field Change
03-01-07 06:16 resinossi New Issue
03-02-07 01:17 resinossi Issue Monitored: resinossi
05-16-07 09:50 klemen Note Added: 0001932
06-06-07 16:17 ferg Assigned To  => ferg
06-06-07 16:17 ferg Status new => closed
06-06-07 16:17 ferg Resolution open => fixed
06-06-07 16:17 ferg Fixed in Version  => 3.1.2


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker