Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001584 [Resin] minor always 01-24-07 13:13 05-03-07 14:47
Reporter geira View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.0.19
Summary 0001584: Problem with Hessian and Spring
Description I am using Hessian together with Spring and HessianProxyFactoryBean. When a webapp is configured to access another webapp within the same Resin instance, - the whole Resin instance freezes during startup. This is caused by the method with signature: Object create(Class api, String urlName) in the HessianProxyFactory class. It happens when the HttpURLConnection tries to open an inputstream through InputStream is = conn.getInputStream(); before the "Hessian-server" webapp is up running...

I solved this problem myself by extending the HessianProxyFactoryBean and overriding the create method, -and implement setReadTimeout(readTimeout); to the connection object.

This should be taken care of in the standard build of the HessianProxyFactoryBean.

Rgds.

Geir A.
Additional Information
Attached Files

- Relationships

- Notes
(0001981)
ferg
05-03-07 14:47

HessianProxyFactory now has a setReadTimeout (i.e. a <read-timeout>) value.

Also, Resin Pro 3.1.2 will not listen for events until the web-app has completed startup.
 

- Issue History
Date Modified Username Field Change
01-24-07 13:13 geira New Issue
05-03-07 14:47 ferg Note Added: 0001981
05-03-07 14:47 ferg Assigned To  => ferg
05-03-07 14:47 ferg Status new => closed
05-03-07 14:47 ferg Resolution open => fixed
05-03-07 14:47 ferg Fixed in Version  => 3.1.2


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker