Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001525 [Resin] block have not tried 12-22-06 12:29 05-22-07 10:45
Reporter westrupp View Status public  
Assigned To ferg
Priority high Resolution fixed  
Status closed   Product Version 3.0.22
Summary 0001525: Resin JNI library is not found on startup (sparc-sun-solaris2.10)
Description Using Resin 3.0.22 on solaris 10,
./configure and make seem to create the library fine.
The library (libresin_os.so) appears to have been
created without problems in the libexec directory (script output is attached).
But on startup, Resin throws an exception and a message saying the JNI library is not found (attached).
Additional Information bash-3.00# cd ..
bash-3.00# cd resin-pro-3.0.22/
bash-3.00# make clean
(cd modules/c/src; make clean)
for dir in resin resinssl; do \
  (cd $dir; make clean); \
        done
rm -f *.o *.so resin
rm -f *.o *.so
bash-3.00# rm libexec/*.so
bash-3.00# ./configure
checking build system type... sparc-sun-solaris2.10
checking host system type... sparc-sun-solaris2.10
checking target system type... sparc-sun-solaris2.10
checking for a BSD-compatible install... automake/install-sh -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... no
checking for nawk... nawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... none
checking for ld used by GCC... /usr/ccs/bin/ld
checking if the linker (/usr/ccs/bin/ld) is GNU ld... no
checking for egrep... egrep
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking sys/poll.h usability... yes
checking sys/poll.h presence... yes
checking for sys/poll.h... yes
checking for /usr/ccs/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/ccs/bin/nm -p
checking for a sed that does not truncate output... /usr/bin/sed
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking command to parse /usr/ccs/bin/nm -p output... ok
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for ranlib... ranlib
checking for strip... strip
checking for objdir... .libs
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... no
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... yes
checking if gcc supports -fno-rtti -fno-exceptions... no
checking whether the linker (/usr/ccs/bin/ld) supports shared
libraries...
yes
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... no
checking dynamic linker characteristics... solaris2.10 ld.so
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
creating libtool
checking for JAVA_HOME... /usr/java
checking if Java is 64-bit... yes
checking for JNI in /usr/java/include/solaris ... found
Using JVMTI for class reloading
Using JVMDI for class reloading
Openssl library was not found
configure: creating ./config.status
config.status: creating Makefile
config.status: creating bin/wrapper.pl
config.status: creating modules/c/src/Makefile
config.status: creating modules/c/src/common/Makefile
config.status: creating modules/c/src/apache1/Makefile
config.status: creating modules/c/src/apache2/Makefile
config.status: creating modules/c/src/resin_os/Makefile
config.status: creating contrib/init.resin
config.status: executing depfiles commands
configure: creating ./config.status
config.status: creating Makefile
config.status: creating bin/wrapper.pl
config.status: creating modules/c/src/Makefile
config.status: creating modules/c/src/common/Makefile
config.status: creating modules/c/src/apache1/Makefile
config.status: creating modules/c/src/apache2/Makefile
config.status: creating modules/c/src/resin_os/Makefile
config.status: creating contrib/init.resin
config.status: creating modules/c/src/resin/Makefile
config.status: creating modules/c/src/resinssl/Makefile
config.status: executing depfiles commands
bash-3.00# make
(cd modules/c/src; make)
for dir in common resin resinssl resin_os resin_os; do (cd $dir; make);
done
gcc -c -g -O2 -DPOLL -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI
stream.c
gcc -c -g -O2 -DPOLL -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI
config.c
gcc -c -g -O2 -DPOLL -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI
memory.c
/usr/ccs/bin/ld -r -o common.o stream.o config.o memory.o
/opt/resin-pro-3.0.22/libtool --silent --mode=compile gcc -o stream.lo
-c
-g -O2 -DPOLL -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI stream.c
/opt/resin-pro-3.0.22/libtool --silent --mode=compile gcc -o config.lo
-c
-g -O2 -DPOLL -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI config.c
/opt/resin-pro-3.0.22/libtool --silent --mode=compile gcc -o memory.lo
-c
-g -O2 -DPOLL -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI memory.c
gcc -g -O2 -DPOLL -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI
-DRESIN_HOME=\"/opt/resin-pro-3.0.22\" -I/usr/java/include
-I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -m64
-fPIC
-c std.c
gcc -g -O2 -DPOLL -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI
-DRESIN_HOME=\"/opt/resin-pro-3.0.22\" -I/usr/java/include
-I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -m64
-fPIC
-c memory.c
gcc -g -O2 -DPOLL -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI
-DRESIN_HOME=\"/opt/resin-pro-3.0.22\" -I/usr/java/include
-I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -m64
-fPIC
-c jni_vfs.c
gcc -g -O2 -DPOLL -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI
-DRESIN_HOME=\"/opt/resin-pro-3.0.22\" -I/usr/java/include
-I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -m64
-fPIC
-c java.c
gcc -g -O2 -DPOLL -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI
-DRESIN_HOME=\"/opt/resin-pro-3.0.22\" -I/usr/java/include
-I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -m64
-fPIC
-c boot.c
/usr/ccs/bin/ld -G -fPIC -o libresin.so std.o memory.o jni_vfs.o java.o
boot.o -lnsl -lsocket -lthread
gcc -g -O2 -DPOLL -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI
-DRESIN_HOME=\"/opt/resin-pro-3.0.22\" -I/usr/java/include
-I/usr/java/include/solaris -I../common -I../resin -DCPU=\"sparcv9\"
-DOS=
-m64 -fPIC -c ssl_stub.c
/usr/ccs/bin/ld -G -fPIC -o libresinssl.so ssl_stub.o ../resin/memory.o
../resin/std.o ../resin/java.o -lnsl -lsocket -lthread
gcc -g -O2 -DPOLL -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI -m64
-DRESIN_HOME=\"/opt/resin-pro-3.0.22\" -I/usr/java/include
-I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -fPIC
-c
jni_os.c
gcc -g -O2 -DPOLL -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI -m64
-DRESIN_HOME=\"/opt/resin-pro-3.0.22\" -I/usr/java/include
-I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -fPIC
-c
jni_jvmti.c
gcc -g -O2 -DPOLL -DB64 -D__SOLARIS__ -DHAS_JVMTI -DHAS_JVMDI -m64
-DRESIN_HOME=\"/opt/resin-pro-3.0.22\" -I/usr/java/include
-I/usr/java/include/solaris -I../common -DCPU=\"sparcv9\" -DOS= -fPIC
-c
jni_jvmdi.c
/usr/ccs/bin/ld -G -fPIC -o libresin_os.so jni_os.o jni_jvmti.o
jni_jvmdi.o
-lnsl -lsocket -lthread
bash-3.00# make install
(cd modules/c/src; make install)
for dir in common resin resinssl resin_os resin_os; do (cd $dir; make
install); done
mkdir /opt/resin-pro-3.0.22/libexec
mkdir: Failed to make directory "/opt/resin-pro-3.0.22/libexec"; File
exists
*** Error code 2 (ignored)
cp libresin.so /opt/resin-pro-3.0.22/libexec
mkdir /opt/resin-pro-3.0.22/libexec
mkdir: Failed to make directory "/opt/resin-pro-3.0.22/libexec"; File
exists
*** Error code 2 (ignored)
cp libresinssl.so /opt/resin-pro-3.0.22/libexec
mkdir /opt/resin-pro-3.0.22/libexec
mkdir: Failed to make directory "/opt/resin-pro-3.0.22/libexec"; File
exists
*** Error code 2 (ignored)
cp libresin_os.so /opt/resin-pro-3.0.22/libexec
mkdir /opt/resin-pro-3.0.22/libexec
mkdir: Failed to make directory "/opt/resin-pro-3.0.22/libexec"; File
exists
*** Error code 2 (ignored)
cp libresin_os.so /opt/resin-pro-3.0.22/libexec
if test /opt/resin-pro-3.0.22 != `pwd`; then \
  mkdir -p /opt/resin-pro-3.0.22/lib; \
  mkdir -p /opt/resin-pro-3.0.22/libexec; \
  cp -r libexec/* /opt/resin-pro-3.0.22/libexec; \
  cp lib/*.jar /opt/resin-pro-3.0.22/lib; \
  mkdir -p /opt/resin-pro-3.0.22/bin; \
  cp bin/* /opt/resin-pro-3.0.22/bin; \
  mkdir -p /opt/resin-pro-3.0.22/webapps; \
  cp -r webapps/* /opt/resin-pro-3.0.22/webapps; \
  mkdir -p /opt/resin-pro-3.0.22/conf; \
  cp conf/resin.conf /opt/resin-pro-3.0.22/conf/resin.conf.orig; \
  cp conf/app-default.xml
/opt/resin-pro-3.0.22/conf/app-default.xml.orig; \
  if test ! -r /opt/resin-pro-3.0.22/conf/resin.conf; then \
    cp conf/resin.conf /opt/resin-pro-3.0.22/conf/resin.conf; \
    cp conf/app-default.xml /opt/resin-pro-3.0.22/conf/app-default.xml;
\
  fi; \
fi
bash-3.00# pwd
/opt/resin-pro-3.0.22
bash-3.00# bin/httpd.sh


....(lots of other stuff here....)

[2006/12/22 08:35:01.640] HostController[] active
[2006/12/22 08:35:01.644]
PortMXBean[resin:type=Port,name=INADDR_ANY-8080]
registered in
MBeanContext[EnvironmentClassLoader$2994589[servlet-server:]]
[2006/12/22 08:35:01.661] Socket JNI library is not available.
[2006/12/22 08:35:01.661] Resin will still run but performance will be
slower.
[2006/12/22 08:35:01.661] To compile the Socket JNI library on Unix,
use
./configure; make; make install.
[2006/12/22 08:35:01.679] java.io.IOException: Can't open OpenSSL port
'0.0.0.0:8080' because JNI support has not been compiled.
[2006/12/22 08:35:01.679] On Unix, run ./configure; make; make
install.
[2006/12/22 08:35:01.679] at
com.caucho.vfs.JniServerSocketImpl.create(JniServerSocketImpl.java:102)
[2006/12/22 08:35:01.679] at
sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[2006/12/22 08:35:01.679] at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39
)
[2006/12/22 08:35:01.679] at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl
.java:25)
[2006/12/22 08:35:01.679] at
java.lang.reflect.Method.invoke(Method.java:585)
[2006/12/22 08:35:01.679] at
com.caucho.vfs.QJniServerSocket.createJNI(QJniServerSocket.java)
[2006/12/22 08:35:01.679] at
com.caucho.vfs.QJniServerSocket.create(QJniServerSocket.java:75)
[2006/12/22 08:35:01.679] at
com.caucho.vfs.QJniServerSocket.create(QJniServerSocket.java:64)
[2006/12/22 08:35:01.679] at
com.caucho.server.port.Port.bind(Port.java:683)
[2006/12/22 08:35:01.679] at
com.caucho.server.resin.ServletServer.bindPorts(ServletServer.java:1015)
[2006/12/22 08:35:01.679] at
com.caucho.server.resin.ServletServer.start(ServletServer.java:975)
[2006/12/22 08:35:01.679] at
com.caucho.server.deploy.DeployController.startImpl(DeployController.java:62
1)
[2006/12/22 08:35:01.679] at
com.caucho.server.deploy.AbstractDeployControllerStrategy.start(AbstractDepl
oyControllerStrategy.java:56)
[2006/12/22 08:35:01.679] at
com.caucho.server.deploy.DeployController.start(DeployController.java:517)
[2006/12/22 08:35:01.679] at
com.caucho.server.resin.ResinServer.start(ResinServer.java:551)
[2006/12/22 08:35:01.679] at
com.caucho.server.resin.Resin.init(Resin.java)
[2006/12/22 08:35:01.679] at
com.caucho.server.resin.Resin.main(Resin.java:625)
[2006/12/22 08:35:01.692] http listening to *:8080

Attached Files

- Relationships

- Notes
(0001752)
svdesign
01-02-07 09:20

Confirmed exactly these problem in my Ubuntu 6.10 system. Wait for solution.
 

- Issue History
Date Modified Username Field Change
12-22-06 12:29 westrupp New Issue
01-02-07 09:20 svdesign Note Added: 0001752
05-22-07 10:45 ferg Assigned To  => ferg
05-22-07 10:45 ferg Status new => closed
05-22-07 10:45 ferg Resolution open => fixed
05-22-07 10:45 ferg Fixed in Version  => 3.1.1


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
30 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker