Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001444 [Quercus] major always 11-07-06 06:49 11-02-06 17:58
Reporter KnisterPeter View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.0
Summary 0001444: Sending null as parameter from PHP to a Java class fails
Description When a parameter value of a Java method is null (called from PHP) then on the javaside the values are as following:
  for String -> empty String
  for int -> 0
  for Long -> 0

=> this blocks e.g. using Hessian as intended from PHP when a Nulled parameter has a special meaning.
Additional Information
Attached Files

- Relationships

- Notes
(0001630)
ferg
11-02-06 17:58

php/0c1y, php/3c1y
 

- Issue History
Date Modified Username Field Change
11-07-06 06:49 KnisterPeter New Issue
11-08-06 07:16 KnisterPeter Issue Monitored: KnisterPeter
11-09-06 02:48 nam Status new => assigned
11-09-06 02:48 nam Assigned To  => nam
11-02-06 17:58 ferg Note Added: 0001630
11-02-06 17:58 ferg Assigned To nam => ferg
11-02-06 17:58 ferg Status assigned => closed
11-02-06 17:58 ferg Resolution open => fixed
11-02-06 17:58 ferg Fixed in Version  => 3.1.0


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker