Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001438 [Resin] major always 11-03-06 04:57 05-01-07 11:24
Reporter spoty View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.1.0
Summary 0001438: Does not allow schema qualification or override with schema attribute
Description At 3.0.21 and 3.1 snapshot, qualifying table name in @table causes error during compiling of bean. Using "schema" attribute on @table produces same results.
Additional Information Message:

com.caucho.config.ConfigException: 'logbook.entries' is not a valid database table. Either the table needs to be created or the create-database-tables attribute must be set.

Use to work. Tried using "schema" attribute instead, but produced same error. Database is postgresql. JDBC driver is postgresql-8.1-405.jdbc3.jar by putting in <root>/lib/local
Attached Files

- Relationships

- Notes
(0001574)
spoty
11-05-06 07:17
edited on: 11-05-06 07:49

This is a stupid user problem. Postgresql requires quoting of identifiers to get mixed-case support.

My table name is nav.NfdcFacilities and this fixed the problem:

@table(name="nav.\"NfdcFacilities\"")

It also requires quoting of @column(name="..."), because of the same complaint during creating of the bean implementation.

However, this creates other problems, because when the bean is compiled, the quotes are imbedded in the strings for performing database operations within the bean implementation. See following example of the compiler error generated:

/Users/catkins/resin/resin-pro-3.1.s061026/webapps/nav/WEB-INF/work/pre-enhance/temp/NfdcFacilitiesBean__ResinExt.java:181:
';' expected
      String sql = "select o."Type" from nav."NfdcFacilities" o where o."SiteNumber"=?";
                              ^
/Users/catkins/resin/resin-pro-3.1.s061026/webapps/nav/WEB-INF/work/pre-enhance/temp/NfdcFacilitiesBean__ResinExt.java:268:
';' expected
    String sql = "insert into nav."NfdcFacilities" ("SiteNumber", "Type") values (?, ?)";
                                   ^
/Users/catkins/resin/resin-pro-3.1.s061026/webapps/nav/WEB-INF/work/pre-enhance/temp/NfdcFacilitiesBean__ResinExt.java:320:
';' expected
    String sql = "delete from nav."NfdcFacilities" where "SiteNumber"=?";
                                   ^
3 errors

 
(0001971)
ferg
05-01-07 11:24

jpa/0g11, jpa/0g2f
 

- Issue History
Date Modified Username Field Change
11-03-06 04:57 spoty New Issue
11-05-06 07:17 spoty Note Added: 0001574
11-05-06 07:49 spoty Note Edited: 0001574
05-01-07 11:24 ferg Note Added: 0001971
05-01-07 11:24 ferg Assigned To  => ferg
05-01-07 11:24 ferg Status new => closed
05-01-07 11:24 ferg Resolution open => fixed
05-01-07 11:24 ferg Fixed in Version  => 3.1.2


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
32 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker