Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001409 [Resin] major always 10-13-06 02:12 11-01-06 14:46
Reporter ckchris View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.0.21
Summary 0001409: work-dir is not being picked up
Description I have <work-dir> within my resin.conf file and it is not getting picked up by Resin for some reason. I have tried putting it under <server>, <web-app-default>, and <host>. None of them work. <temp-dir> works just fine though.

However, if I put <work-dir> within <web-app> in a resin-web.xml file, then it will get picked up and recognized.

Additional Information
Attached Files

- Relationships

- Notes
(0001543)
ckchris
10-13-06 13:16

I have done more testing and I believe I know what the problem is:

I put <work-dir> and <temp-dir> inside my app-default.xml's <web-app-default> tag. Within the tag, this is what I used:

<work-dir>${server.root}/work/${host.name}/${app.name}</work-dir>
<temp-dir>${server.root}/tmp/${host.name}/${app.name}</temp-dir>


Strangely, <temp-dir> is parsed fine and directory is created under ${server.root} (which is /var/resin). However, I get problems with <work-dir> and it always defaults to WEB/work.

When I change ${server.root} to "/var/resin" so that it becomes:

<work-dir>/var/resin/work/${host.name}/${app.name}</work-dir>

Everything works with this.

Am I using ${server.root} wrong or something? Also, my server.root is different from my resin.home.

Thanks
 
(0001621)
ferg
11-01-06 14:46

server/12aa
 

- Issue History
Date Modified Username Field Change
10-13-06 02:12 ckchris New Issue
10-13-06 13:16 ckchris Note Added: 0001543
11-01-06 14:46 ferg Note Added: 0001621
11-01-06 14:46 ferg Assigned To  => ferg
11-01-06 14:46 ferg Status new => closed
11-01-06 14:46 ferg Resolution open => fixed
11-01-06 14:46 ferg Fixed in Version  => 3.1.0


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker