Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000131 [Resin] minor always 05-02-05 00:00 11-01-05 14:45
Reporter sam View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.0.12
Summary 0000131: EJB3 with MySQL ArrayIndexOutOfBoundsException: 856
Description RSN-122
[10:16:43.760] 0.66:prepareStatement(UPDATE license SET customer=?, issueDate=?, name=? WHERE ID=?)
[10:16:43.840] 0.66:setLong(1,228)
[10:16:43.840] 0.66:setTimestamp(2,2005-05-02 15:16:43.299)
[10:16:43.850] 0.66:exn-setTimestamp(java.lang.ArrayIndexOutOfBoundsException: 856)
[10:16:43.850] 0.60:close()
[10:16:43.850] 0.61:close()
[10:16:43.850] 0.62:close()
[10:16:43.850] 0.63:close()
[10:16:43.850] 0.64:close()
[10:16:43.850] 0.65:close()
[10:16:43.850] 0.66:close()
[10:16:43.850] idle PoolItem[jdbc/ReadWrite,0,com.caucho.sql.ManagedConnectionImpl@c6e1ec]
[10:16:43.850] 0:clearWarnings()
[10:16:43.850] com.caucho.amber.AmberRuntimeException: com.caucho.sql.SQLExceptionWrapper: java.lang.ArrayIndexOutOfBoundsException: 856
[10:16:43.850] at com.caucho.amber.connection.AmberConnectionImpl.cleanup(AmberConnectionImpl.java:1103)
[10:16:43.850] at com.caucho.ejb.entity2.EntityManagerImpl.close(EntityManagerImpl.java:268)
[10:16:43.850] at com.caucho.jca.UserTransactionImpl.abortTransaction(UserTransactionImpl.java:433)
[10:16:43.850] at com.caucho.jca.UserTransactionProxy.abortTransaction(UserTransactionProxy.java:174)
[10:16:43.850] at com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:183)
[10:16:43.850] at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:208)
[10:16:43.850] at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:259)
[10:16:43.850] at com.caucho.server.port.TcpConnection.run(TcpConnection.java:341)
[10:16:43.850] at com.caucho.util.ThreadPool.runTasks(ThreadPool.java:490)
[10:16:43.850] at com.caucho.util.ThreadPool.run(ThreadPool.java:423)
[10:16:43.850] at java.lang.Thread.run(Thread.java:595)
[10:16:43.850] Caused by: com.caucho.sql.SQLExceptionWrapper: java.lang.ArrayIndexOutOfBoundsException: 856
[10:16:43.850] at com.caucho.sql.SQLExceptionWrapper.create(SQLExceptionWrapper.java:82)
[10:16:43.850] at com.caucho.sql.spy.SpyPreparedStatement.setTimestamp(SpyPreparedStatement.java:400)
[10:16:43.850] at com.caucho.sql.UserPreparedStatement.setTimestamp(UserPreparedStatement.java:307)
[10:16:43.850] at com.caucho.hogwarts.License.__caucho_flush(License.java)
[10:16:43.850] at com.caucho.amber.connection.AmberConnectionImpl.flush(AmberConnectionImpl.java:605)
[10:16:43.850] at com.caucho.amber.connection.AmberConnectionImpl.cleanup(AmberConnectionImpl.java:1101)
[10:16:43.850] ... 10 more
[10:16:43.850] Caused by: java.lang.ArrayIndexOutOfBoundsException: 856
[10:16:43.850] at com.caucho.bytecode.ByteCodeClassScanner.parseConstantPoolEntry(ByteCodeClassScanner.java:176)
[10:16:43.850] at com.caucho.bytecode.ByteCodeClassScanner.parseConstantPool(ByteCodeClassScanner.java:130)
[10:16:43.850] at com.caucho.bytecode.ByteCodeClassScanner.scan(ByteCodeClassScanner.java:81)
[10:16:43.850] at com.caucho.loader.enhancer.EnhancerManager.enhance(EnhancerManager.java:236)
[10:16:43.850] at com.caucho.loader.DynamicClassLoader.loadClass(DynamicClassLoader.java:1168)
[10:16:43.850] at com.caucho.loader.DynamicClassLoader.findClass(DynamicClassLoader.java:1082)
[10:16:43.850] at com.caucho.loader.DynamicClassLoader.loadClass(DynamicClassLoader.java:1012)
[10:16:43.850] at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
[10:16:43.850] at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
[10:16:43.850] at com.mysql.jdbc.PreparedStatement.setTimestampInternal(PreparedStatement.java:2068)
[10:16:43.850] at com.mysql.jdbc.PreparedStatement.setTimestamp(PreparedStatement.java:1168)
[10:16:43.850] at com.caucho.sql.spy.SpyPreparedStatement.setTimestamp(SpyPreparedStatement.java:396)
[10:16:43.850] ... 14 more
Additional Information
Attached Files

- Relationships

- Notes
(0000156)
ferg
05-02-05 00:00

This isn't actually an EJB3 issue, it's a bytecode enhancement issue.

The exception is now swallowed, and a log entry added.
 

- Issue History
Date Modified Username Field Change
05-02-05 00:00 sam New Issue
11-01-05 00:00 administrator Fixed in Version  => 3.0.14
11-01-05 14:45 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker