Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001295 [Resin] minor sometimes 08-17-06 14:23 08-02-06 10:34
Reporter sks View Status public  
Assigned To ferg
Priority normal Resolution fixed  
Status closed   Product Version 3.0.21
Summary 0001295: java.lang.IllegalStateException: attempted to add listener to a closed classloader
Description I don't know if this is serious or not but it's in my log files.


[22:21:41.921] java.lang.IllegalStateException: attempted to add listener to a closed classloader EnvironmentClassLoader$24152206[web-app:http://localhost:80/e602] [^]
[22:21:41.921] at com.caucho.loader.DynamicClassLoader.addListener(DynamicClassLoader.java:564)
[22:21:41.921] at com.caucho.loader.Environment.addClassLoaderListener(Environment.java:184)
[22:21:41.921] at com.caucho.jmx.MBeanContext.<init>(MBeanContext.java:122)
[22:21:41.921] at com.caucho.jmx.EnvironmentMBeanServer.getContext(EnvironmentMBeanServer.java)
[22:21:41.921] at com.caucho.jmx.Jmx.copyContextProperties(Jmx.java:134)
[22:21:41.921] at com.caucho.management.server.AbstractManagedObject.getObjectName(AbstractManagedObject.java:70)
[22:21:41.921] at com.caucho.management.server.AbstractManagedObject.registerSelf(AbstractManagedObject.java:125)
[22:21:41.921] at com.caucho.server.session.SessionManagerAdmin.<init>(SessionManagerAdmin.java:56)
[22:21:41.921] at com.caucho.server.session.SessionManager.<init>(SessionManager.java:235)
[22:21:41.921] at com.caucho.server.webapp.Application.getSessionManager(Application.java:2262)
[22:21:41.921] at com.caucho.server.connection.AbstractHttpRequest.getSessionManager(AbstractHttpRequest.java:1494)
[22:21:41.921] at com.caucho.server.connection.AbstractHttpRequest.createSession(AbstractHttpRequest.java:1435)
[22:21:41.921] at com.caucho.server.connection.AbstractHttpRequest.getSession(AbstractHttpRequest.java:1256)
[22:21:41.921] at com.caucho.server.connection.AbstractHttpResponse.writeHeaders(AbstractHttpResponse.java:1555)
[22:21:41.921] at com.caucho.server.connection.ResponseStream.writeHeaders(ResponseStream.java:219)
[22:21:41.921] at com.caucho.server.connection.ResponseStream.writeNext(ResponseStream.java:406)
[22:21:41.921] at com.caucho.server.connection.ToByteResponseStream.flushByteBuffer(ToByteResponseStream.java:518)
[22:21:41.921] at com.caucho.server.connection.ToByteResponseStream.flushBuffer(ToByteResponseStream.java:424)
[22:21:41.921] at com.caucho.server.connection.ResponseStream.getBuffer(ResponseStream.java:228)
[22:21:41.921] at com.caucho.vfs.i18n.ISO8859_1Writer.write(ISO8859_1Writer.java:106)
[22:21:41.921] at com.caucho.server.connection.ToByteResponseStream.flushCharBuffer(ToByteResponseStream.java:469)
[22:21:41.921] at com.caucho.server.connection.ResponseStream.finish(ResponseStream.java:662)
[22:21:41.921] at com.caucho.server.connection.ResponseStream.close(ResponseStream.java:799)
[22:21:41.921] at com.caucho.server.connection.AbstractHttpResponse.finish(AbstractHttpResponse.java:1955)
[22:21:41.921] at com.caucho.server.connection.AbstractHttpResponse.close(AbstractHttpResponse.java:260)
[22:21:41.921] at com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:190)
[22:21:41.921] at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:229)
[22:21:41.921] at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:274)
[22:21:41.921] at com.caucho.server.port.TcpConnection.run(TcpConnection.java:511)
[22:21:41.921] at com.caucho.util.ThreadPool.runTasks(ThreadPool.java:516)
[22:21:41.921] at com.caucho.util.ThreadPool.run(ThreadPool.java:442)
[22:21:41.921] at java.lang.Thread.run(Unknown Source)
Additional Information
Attached Files

- Relationships

- Notes
(0001485)
ferg
08-02-06 10:34

It's a web-app shutdown/timing issue. Resin shouldn't be recreating the SessionManager when the WebApp is closing. The fix is in 3.1.0 (since it's just adding a different warning in that situation.)
 

- Issue History
Date Modified Username Field Change
08-17-06 14:23 sks New Issue
08-02-06 10:34 ferg Note Added: 0001485
08-02-06 10:34 ferg Assigned To  => ferg
08-02-06 10:34 ferg Status new => closed
08-02-06 10:34 ferg Resolution open => fixed
08-02-06 10:34 ferg Fixed in Version  => 3.1.0


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker